Xbox One Matchmaking: Always Searching


#1

For the past week now I could never join a match, when I queued in the matchmaking system it would say it was “searching” for players but I am never placed in a lobby and just stuck in limbo with nothing to do. I been very patient waiting for this issue to be sorted out and after about a weeks time I had just about enough of this.
I buy games to play them, not to sit in limbo twiddling my thumbs. I have no idea whats causing it, and it never happened before, even when I played in the Alpha and Beta respectively.

I know its nothing wrong on my side cause I am only having connection issues with this game exclusively. If it does not get sorted out soon I might as well try to get a refund or something, kinda pointless having a game you cannot actually play…


#2

I’m having the same problem. Can’t find a game in either modes.

I was doing fine for the goliath rock throw challenge, but now I’m getting nothing for games.


#3

Same here. I have been trying everyday at different times of the day for about a week now to try and join a game, but it will never find anything. I am very disappointed that this has not been fixed yet. I unfortunately am unable to get a refund having gotten the game from gamestop and it has been more than a month from purchasing the game and I know I wouldn’t be able to refund the new hunters I got either.

I tried uninstalling and re installing the game, but that hasn’t worked (even though it has worked for any other problems that did arise with the game before).

If this isn’t fixed or given a special refund opportunity, I will never buy a game from Turtle Rock Studios and I would not recommend any future games from Turtle Rock Studios to anybody.


#4

Ya I’m having this problem among many other very often as well… This game has gotten worse for me since the patch and micro patch came out…


#5

i was getting this a lot during alpha.
Try going into your router and setting up the ports for your xbox one.

http://support.xbox.com/en-US/xbox-one/networking/network-ports-used-xbox-live

Opening up UDP 3074 fixed this issue on my xbox one.
Occasionally, if there’s a power failure or something, i’ll have to re-enter this info.
Get the IP of your xbox one in the system settings, enter them in the router and you should be good to go.

Follow the instructions on the xbox link i posted above.


#6

I don’t really think that is the solution though, why would I need to open ports just to play a specific game? If the problem was more widspread and was problematic across the board with all games, I could see this being necessary as its clearly my connection, however this is not the case.
Also considering that I never had an issue like this, even during the Alpha and Beta, it makes me even more skeptical.
I think the root of the cause was from a patch like BooneYO has mentioned, ever since the latest patch the game just refuses to work.


#7

It might still be something specific to Evolve. Maybe it doesn’t like playing with routers…

But anyway, i was playing the master chief collection until evolve launched and never had a problem with my router there. Got evolve and wasn’t linking to other players. Opened the ports and now everything’s gravy.

Maybe not your issue, true, but worth a shot!

Easy to do, costs no dollars, possible fix!