Wraith teir three mastery bug!


#1

Ok I’m trying to get the teir three done for Wraith but the supernova refuses to give me credit ex: it says damage using abilities 70 times while supernova is active I use supernova then decoy that should count but didn’t work so I use supernova then warp blast and abduction still doesn’t work what’s the deal with this? Bug or am I doing something wrong?
Edit: system PS4


#2

i just finished my 3stars on wraith today and for me it worked all of the above that you mentioned ! nova>decoy>warp blast then abduct , not sure which worked but one of those counted for sure because it updated.


#3

Well it worked for like 5 but then it refuses to work beyond that and I did multiple rounds trying to do it.


#4

Decoy does not actually count towards the total. The ability must be completed -inside- the supernova arena. I’d simply pop supernova, abduct someone who’s inside it, then warp blast their face off. It worked like a charm.

Now just you wait for that shitty “abduct 225 hunters from their team” mastery, THEN you’ll rage.


#5

I’ll try again. Lmao I know I seen that and was like wth why would they do this to me!
Edit: yeah I must have been doing it wrong now I’m getting it


#6

Yes, Supernova then Warp Blast.


#7

For the abduction mastery do you have to abduct them an x amount of meters or is it abduction period? If it’s x how far is x?


#8