(Workaround/Fix) Low Frame Rate Bug on high-end PC (GTX 980)


#1

Like many others with high-end PCs, I’ve had less than satisfactory frame rates when playing Evolve. I’m running an i7-3770K @ 4.4GHz + GTX 980, using an SSD and 1080p 60hz monitor with all drivers up to date, and sometimes when I open the game I get a normal expected performance of around 90-150+ fps like most benchmarks have been showing with my setup. Then there will be other random times when I run the game and the frame rate hovers between 50-60 fps under the same graphical conditions.

The performance I’m about to get becomes evident as soon as the game loads onto the character selection screen, and sometimes it will be just under 60fps, and other times it will be over 150. When it’s under 60fps, it will stay around that and be under that number for the rest of the game.

The curious thing is, when I have a Chrome window open in the background the issue fixes itself and game performance shoots back up. When I close Chrome and have no other windows open but Evolve, performance degrades again, and I can’t press the desktop key or minimize the Evolve application window either unless I force Ctrl+Alt+Del. Then I’ll open a Chrome window, click back into Evolve and see the frame rate go back up from ~50fps to 100 (although I did get some stuttering afterwards and an eventual crash to desktop. This may have something to do with the latest Nvidia drivers 347.52 and the “DXGI_ERROR_DEVICE_HUNG” people have been reporting).

This made me wonder whether Chrome (or another internet browser like Firefox) is running some kind of script that Evolve isn’t utilizing, such as the full GPU capability. If any of you are getting strangely low frame rates but can’t seem to figure out why it’s sometimes fine and sometimes not, try having an internet browser open in the background and see if it improves anything.


PC Stuttering and framerate dips
[Logged] Low framerate during the gameplay
[PC] FPS drops, not using VRAM
#2

I’ll give this a shot OP and see what happens. I’ll report back shortly!

EDIT: Didn’t do anything for me. Still runs at 25 FPS in the drop ship and 51 FPS in the menus and 45-60 fps in game. Oh well. Glad that seems to work for you though!


#3

I was having exactly the same problem, and im running an i7 4790K with two eVGA GTX780 6GB ver cards, getting a lousy 50 fps max ingame (solo mode) to be exact. I tried everything from disabling HT, disabled SLi, created autoexec.cfg with sys_MaxFps = 120. Stumbled on your fix when almost all hope was lost, launched chrome in the background, boom, 100~ fps ingame.

Thank you!!!


#4

What are your PC specs? If you’re getting 25 FPS in places then it may just be a low hardware configuration


#5

That’s great to know you were able to fix it! Alternatively instead of a Chrome window I tried opening the Battle.net client in the background and it worked as well to eliminate the frame rate throttling. I’m guessing any application which utilizes the GPU to some extent will help resolve the problem. There are however other hiccups and stutters in the game which I’ve noticed, mainly happens when an event triggers or asset-loading such as the monster evolving, or getting hit by a specific wildlife for the first time. I play with v-sync on and when the game stutters it always drops a few frames before going back up.


#6

I run 5960 and firepro w9100. Chrome doesn’t fix the issue for me but notice when I run Premiere Pro it gives me a boost while it idles in the background.


#7

i5 4690k @ 4.4ghz and an R9 290. My PC is not a low config at all.

The issue I have is all settings run at the same FPS and 25 FPS in the drop ship. It didn’t do this in the beta at all, which is why I’m so confused as to why this is happening.

I’m just blaming poor optimization or lack of AMD drivers for the time being.


#8

Damn, I wonder what happened between Beta and launch which introduced so many optimization issues…it seems mid-range systems are getting the best performance.


#9

I should note that i have HT enabled in bios and get 120fps easy in drop ship when chrome is running in background. Without chrome, its a poor 50fps max. With HT disabled, i get above 50fps, but terrible gpu usage and poor sli scaling


#10

Yeah, I have similar performance comparisons to you when enabling/disabling HT as well. Just wondering, do you get random stutters in the game when moving around certain areas of the map, or when events trigger like monster evolving?


#11

Well if you are running texture detail on Very High, you probably are experiencing vram overload as im seeing above 4000mb in use, however my cards have 6GB of vram each.


#12

The stuttering still occurs when I lower all the settings. Someone said it could be related to the day one 3GB patch that “fixed” long loading times, possibly retiring some textures and assets to pre-load before the game starts. This would make complete sense that now with shorter load times, textures, assets and variable events are being loaded on the fly causing stutters. I wonder whether an option or tweak could be made available to pre-load instead. I’d much rather prefer longer load times than constant hitching.


#13

Right. Well i dont have a patch installed, clean install, so that could explain it… even then, loading times dont seem that bad. And mine is installed on a 5400rpm wd green hdd. Lol… sigh