Update: Confirmed with Testing, Release to fire option does not work on several monster abilities on PC


#1

In options I have my monster ability control set to start abilities when the button is released instead of when it is pushed, but when playing Elder Kraken the banshee missile launches when I press the assigned button rather than waiting for the release. All the other abilities wait until I release the assigned buttons.

@TrickshotMcgee @Kishan_Devkaran @Rick @LordDerp

Update 3-1:

I have tested all the monsters on PC and got some interesting results. The ‘release to fire option’ worked properly with most of the monster abilities with the following exceptions: All of Kraken’s abilities; Behemoth’s Fissure; Elder Kraken Banshee Missile and Chain Lightening. I was especially surprised that Elder Kraken had 2 abilities that worked as expected and 2 that did not. I would confirm this as a bug since it only mostly effects Kraken and its variant with one other instance for Behemoth. I would also add that if this is fixed it will have a positive impact on my gameplay, as the abilities that work with ‘release to fire’ have a better user experience regarding timing and aiming.


#2

I think that is intended, but I could be wrong


#3

At first that is what I thought, but then I realized this is the only monster ability that does this, but the whole point of the setting is that a button release is the trigger. Pressing the button down should not trigger the ability.

It is easier/more accurate for me to release a button while I am aiming, than to press a button while I am aiming. That seems to be what the option is for.

Edit, @Rick now that you mention it I think regular Kraken mines do the same thing, I will have to go test. The reason I noticed this is that I kept missing banshee missiles because they were firing when I didn’t expect it. I would still call it a bug or a conflict with the game options. I also think Goliath FB might be on the button press as well, I may need to test other abilities there may be a few that work this way, maybe there is a technical reason.


#4

Does the same not happen with original Kraken’s Banshee Mines?


#5

Exactly what i thought was suppose to happen. I tend to hold the button till the right time and not use it right away like the game does it


#6

It’s not a move with any kind of startup time or anything, so “aiming” in the sense like aiming Rock Throw doesn’t happen. Elder just kind of spits it in the spot you’re looking at.

The same thing happens with a lot of abilities.


#7

Updated title and original post after testing.


#8

Still not certain it’s a bug. If it works that way with that many abilities, consistently for everyone, I don’t think that constitutes as something that shouldn’t happen.


#9

I don’t know if it is a code bug, or certain abilities just were never coded to work with the option as an oversight. 3 out 4 abilities work correctly with the ‘release to fire’ option, and it is almost exclusively a Kraken issue so I am confident it was not intended by the Devs that those abilities not work with that option. There are several issues found by @white_hawke8 that have existed from the release that were errors or bugs. This appears to be similar.

@ArPharazon has this issue been brought to your attention before? I did not find a relevant thread when searching before posting this. Thanks.


#10

Agree that it might be slightly important to know if this is intended or not before calling it a “bug”, or an “issue”, or anything like that lol


#11

Just FYI, I don’t think you should compare Kraken and Elder Kraken, since Kraken can hold-fire VT but EK can’t for the DS.

I played some Kraken not too long ago and I’m 95% certain I was able to hold-fire his VT. Of his abilities, that is the only one that can be held. All others are fire-on-press. As far as I am aware, Banshee Missiles are not intended to be held.

EK’s BMs and CL are not supposed to be held (At least I don’t see them being like that), but are activate on press. Fissure, I believe, is supposed to have outlines on the ground and be held. I feel like I remember back near release seeing outlines on the ground when holding the button.


#12

The ability control options for monster are: Release to Fire; Toggle to Fire (Toggle requires 2 key presses to activate an ability)

I Tested every monster this morning with the ‘release to fire’ option by pressing the ability key and holding it down to see which abilities activated, and which waited until the key was released. Every ability for Both Goliaths, Wraith, and Gorgon did not activate until the key was released. Certain abilities like Rock Throw, Warp Blast, Abduct, and Spider Trap would hold the character in place and show an aiming reticle while the key was depressed and complete the animation once it was released. When holding the key for abilities like Fire Breath, Web Snare, and Decoy I was able to move the monster around the map and use traversals but could not melee or use other abilities until I released the key and completed the original ability.

Behemoth’s abilities all were release to fire with the exception of Fissure which fired as soon as I pressed the key down.

Elder Kraken’s Lightening Strike and Death Spiral don’t activate until the button is released. Chain Lightening and Banshee Missile both activate when the button is pressed even if you hold the button down and don’t release it.

All of Krakens abilities fired upon key press and did not wait until release.

The option description is pretty straight forward and since 3 out of 7 monsters have no deviation and 2 of the remaining 3 monsters only partially deviate the most likely conclusion is that there is an issue with the fire control for Both Krakens and Behemoth’s Fissure. There is no option in the game for ‘Press to Fire.’ I suspect because it is much easier to press and hold a skill shot ability while you track and aim, then release to fire than it is to track and aim and then press the fire key at just the right moment. That is certainly my experience.


#13

this is super interesting… I think then this may of been intended. Only use the ability when you are certain.


#14

In that case, please use the issue reporter to report this. Also include your last message after your description of the bug.