Unsupported video card error with no device information


#1

I recently purchased Evolve on Steam, but when I try to launch the game I get an error that looks like this:

Unsupported video card detected! Continuing to run might lead to unexpected results or crashes. Please check the manual for further information on hardware requirements.
“” [vendor id = 0x0000, device id = 0x0000]

When I click OK, cancel, close the window, or press escape, the error window closes and my steam status changes from in-game back to online.

My graphics card is a ATI Radeon HD 5570. It supports DirectX 11 and I have not had any problems with other games. I have the most recent graphics drivers installed. The error does not show the vendor or device id for my graphics card ("" [vendor id = 0x0000, device id = 0x0000]).

I received the same error when I had an Nvidia GeForce GTS 250 installed, however that card did not support DirectX 11. The error did not display the device or vendor id for the Nvidia card either.

I am running Windows 10 Home, as are 2 of my friends who are able to run Evolve without any issues.

I can’t even launch the game because CryEngine isn’t finding any of my graphics card information. Is this a problem with my operating system, hardware, game installation, or the game itself, and is there any way to fix this?


#2

Wouldn’t have expected to see that. I’m going to guess that it’s a problem with the operating system, because you’ve tried two completely dissimilar cards with the same result. Evolve will call an OS function to ask for the card’s specs. Maybe it returned an error, or something.

Note that this is purely a guess, because I’m at home and I don’t have the code in front of me. I might be able to give a more informed answer after the weekend. Also it would be interesting to know if QA has ever seen this.

Have you tried running Windows Update?


#3

I ran windows update and there are not any updates that I have not installed. I also used GPU-Z to test if other applications are able to view information for my card. GPU-Z was able to display all the correct information for my card (AMD Radeon HD 5570, vendor id 1002, device id 68D9).


#4

Ok. Maybe, then, if I examine the code that queries the graphics card, I might be able to find a way it can fail and return zeros.


#5

I see, the zero ID results come from the game simply not finding your card in its database of known cards. You’re supposed to be able to continue despite this. It should default to low quality if I remember correctly, and then you should be able to manually set up your graphics options.

I think it must be crashing after you choose to proceed by clicking OK. If you hit Cancel, looks like the game’s supposed to exit. I’ll let you know if I find out anything else.


#6

I have fixed the problem; now I can launch Evolve and I don’t even get an error for an unsupported graphics card.

The crash was caused by the force warp feature being enabled for Evolve in dxcpl. The Nvidia card I had only supported directx 10, so I got an AMD card from a friend that supports directx 11. When I had the dx10 card I got the same error and crash that I described in this thread, so I tried to use the dxcpl dialog to make Evolve run as dx10 using by enabling force warp. It didn’t work and I still couldn’t play, so I installed the dx11 card. When I started using the card with dx11, I forgot to disable the force warp feature, but now that I have disabled force warp I am able to launch the game.

My bad, thanks for your help.


#7

Wow that’s great that you figured it out. But I would have hoped Evolve would have a popup telling you that you need DX11, though.


#8

I have the same error and im so angry because I had to wait 5 bloody hours for this thing to be done…but when i click OK it crashes.Im done whit this and I know I can`t do anything.


#9

not hating no one but THIS WAS A BIG WASTE OF TIME…
:frowning: help


#10

Sorry if you wasted your time. Everyone should be sure to check the system requirements section on the store page before downloading.