"Unable to connect to My 2k" Evolve Stage 2

Well, i was playing Evolve Stage 2 for about 2 weeks but yesterday (07/19/2016) my game just can’t connect to my2K account, actually i was playing without linking an my2k account and now can’t play ranked matches, can’t buy any skins or characters. Somebody is having the same problem ?? If anyone can answer me i’ll appreciate it. My Steam profile is http://steamcommunity.com/profiles/76561198075846967/

Im having the exact same problem and from I hear many other are having this problem as well, I keep hearing that you need to uninstall and reinstall the game, so I tried it to no avial and then I reinstalled stea and had to reinstall all 86 of my games which took about 7 hours to no avail so now I ask is this just a bug in the code?, if so this bug completely disables the game, unable to use matchmaking, the store or anything else other than practice mode… is it looking for a connection which I have and just not working? can we get a fix for this?
Steam Profile: http://steamcommunity.com/id/MMO_Nerd

Try this

Same problem still cant connect it does the intro sequence shows my name logging in at the bottom right and then appears with the same message as before

As I’m just a player, not really too in tune with what problems may be, please do check through this thread to see if anything else fits the description of your issue:

I guess I am going to have to wait for a patch or something to fix this since the only forums addressing this problem is this one.

If I could get a reply in the next 3 hours that would be great

Steam Profile: http://steamcommunity.com/id/MMO_Nerd/

I’ll tag in @snowkissed just in case she can shed any more light on it, but I don’t know if she will or not :slight_smile:

1 Like

I had the same problem, i couldnt even log in on the My2K site too, but i sent a support ticket and they changed my nickname from “Duskam” to “DuskamX” and then it was solved :v

Huh Now instead of saying features will not be accessible It just says try again later? Ima try the fix again and see if it want to work now

Ok tried again: no avail this is getting kinda anoying but I will be patient for a fix

If clearing the cache files like the self-help thread says doesn’t work, there isn’t too much we can do on the TRS side and you’ll have to work with 2K Support. For some reason, either your ISP or your IP has an issue reaching my2K services.

It’s odd becuase now I found out that I can play with my friends through steam… and it appears that I can even join matchmaking if I am invited…

Could It have something to do with me having a static IP to my router