UI freezes on character selection [PC]

#1

So this bug has been happening literally everytime I try to join a lobby tonight (PC version)… I join the game just fine, the character selection loads just as it’s expected to, but once I click “Select” to select my character, or go back a step to change role, the interface just freezes and it becomes completely unresponsive. I can’t click on any button. The only thing I can do is use the chat. I’ve basically only had ONE lobby tonight where it unstuck itself randomly, otherwise it just keeps happening. Also it seems like this bug, even if it’s only me who’s experiencing it, is affecting the whole lobby, since when the lobby timer runs out, the game doesn’t start and everyone’s stuck in an endless loading screen.

Tried to verify cache on Steam, no luck. Everything verified properly.

#2

I haven’t really made any updates on this for the last few weeks to I might as well do it now. As I was having connection issues in lots of other games, not just Evolve, I went ahead and changed my old router to a new one, and that seems to have solved all the problems I had. If anyone experiences a similar issue, check to update your router if possible.