Trying to join a session for a different version of the game

Read title. But note it’s not a bug report.


This is the error message I just got for trying to join a friend. I know what it means.
This was confirmed by the game when it suddenly gave me another error message about missing new data and that I have to select “Multiplayer” in order to update.

This raises 2 concerns:

  1. Why isn’t it just taken care of with Steam updates? Since everyone’s gotta update to play multiplayer anyway, why not just use Steam for that?
    I noticed this plenty of times in the past where I got confused whether my game has updated or not. I always try new updates out in Solo first; then I’m surprised to see the old perk values and in this patch’s case, I found Bucket still shooting only 4 missiles and still reloading very slow 2 days ago when I tried it out.
    It’s only then that I realized I had to update all the “values and variables” of the game’s balance which is apparently not done through Steam but by the game itself when you play multiplayer.

But more importantly 2) It doesn’t seem to download until I actually play multiplayer. I don’t think this is how it worked before.

Just now I got a game invite from a friend and I want to join.
First it launches the game and then it gives me the error message shown above.
Turns out I have to not only just go to the multiplayer menu real quick, but actually have to start matchmaking. It’s what I’m currently doing. I’ve already waited 10 minutes and then tried to join my friend; still outdated.

So now in order to join my friend I have to actually waste 10 minutes in the matchmaking screen, get paired with other players, play an entire multiplayer match (or suffer from the demotion and penalty) and then I can play. Or at least that’s what I assume, maybe I have to do something completely different for it to finally start updating already.

Not to mention that Evolve can just as easily do its updating thingy when I join my friend’s match.
There’s no reason why I have to play a random matchmaking round for that.

I had this issue with just 1 friend, and me or my other friend cannot join his games. However, he can join ours or we can all join someone elses. But that 1 friend, cannot host after the patch.