Store Bug, Can't Customize Skins (Pre-ordered Monster PC)


#1

Played all of monday. Could customize my Goliath with a magma/savage skin.
Come Tuesday/Wednesday/today I can’t click customize at all. I can pull up the steam page just fine and have it tell me I got the Season Pass/Pre-order goodies/Monster PC edition. I don’t know if its bugged that the client thinks I don’t own the skins or I just can’t click customize period.

Something I noticed Tuesday is that the store is telling me I purchased everything. Every bundle, every piece of DLC has been purchased but I’ve never bought anything off the store. I can’t click on customize for hunters either.

Anyone have an ETA on when this is getting fixed?
I tried restarting the game 3-4 times. I tried verifying steam cache. Any other solutions? Would reinstalling the entrie game work?


#2

This and the progression issue are known server issues with 2K. They’re working on a fix. Check this link: Do you have XBox Loss of Levels/Progress?

Also if you can supply 2k with more information it might help to resolve this issue.


#3

I contacted them via your link. Thank you for telling me that. At least I know it isn’t just a few of us. Hopefully they keep us informed in the near future.


#4

It is widespread, but not everyone is affected (for better or worse).


#5

Everything is fixed now. Glad they were very quick about it. Store is fine, can customize my monster anyway I want :open_mouth:


#6

Not fixed for me, did you do anything different or did you buy anymore DLC?


#8

Now all of a sudden Mine works now, I tried un-clicking the dlc in the steam settings, and then the game updated (sort-off qued itself for an update then unqued), and then i re-clicked the DLC and the skins started working don’t know if it was a coincidence or a fix since I think i tried that before. but thought I would let everyone know.