Still can't join friends


#1

This was happening in the beta and it doesn’t look to be fixed. The first friend I tried to join ended up with a freeze and then every other time afterwards it just hangs. I bought the game assuming this was a temporary problem. What’s the deal?


#2

Do you have the latest Nvidia drivers? It might solve the issue.


#3

This is on the Xbox One. Matchmaking basically doesn’t work and it was the same way in beta. Getting messages such as "connection has failed’ and “you’re already in the session”.


#4

Bringing
Up
My
Post

Because I don’t understand what has been done since beta?


#5

We can try to summon @MrStrategio in case he haven’t seen this one already. Don’t know if he can help you but at least he will be notified about the issue.


#6

This same issue is happening to me and a friend, and we were hoping it would be fixed from the beta as well. This needs to be fixed, because when we invite each other and search for a game, one of us gets disconnected from the party and the other is put into a game, and since there is a penalty for leaving one of us must wait for the game to finish to ultimate search again, and have the same situation repeat itself. Please fix this issue.


#7

Same issue. Party play/matchmaking is really spotty, takes ~20 minutes to get into the “searching” state with all my friends, not including the actual search time.

As a temporary fix, sometimes when experiencing this problem, my friends and I exited all the way to the main menu, then selected “Multiplayer”, waited for it to enable parties, and then tried again. Works about half the time.


#8

Has anyone heard any official word regarding when things will be fixed? I haven’t found anything saying they’re working on a patch and that these problems will go away. It’s discouraging since these problems were revealed during beta, but here we are still having them. If you’re not going to tell me when it will be fixed, tell me how to get my money back. I didn’t buy a multiplayer game for multiplayer not to work.


#9

I’m bumping my thread yet again because it’s going on a week and no resolve in sight.

We’re on day 4, going on 5. Couple means 2. What’s the deal?


#10

Bringing
Up
My
Post


#11

Same here. Cannot join my friends with evolve. I invite them and they either can’t connect or they say the lobby is full already. Mean while it’s just me playing any ideas how to join your friends gsme?


#12

Gonna keep bumping this until it’s fixed or someone gives some well-deserved answers, otherwise what took place is a straight up robbery. Do I really have to report this to the BBB?


#13

Still has not been been fixed. Is there any support at all for this game?


#14

Still have the problem, bought the game without reading about the multiplayer DC thing, and now i’m enjoying playing solo… but i didn’t play it to play solo… me and my friends can’t play with each others without a DC network problem…
I am on PS4


#15


@TheMountainThatRoars


#16

@Shunty @CptBoomBoom are either of you having this issue?


#17

I’m not, even though it does happen after the game crashes or throws me out of a server. That’s the only time it happens. I usually solve this by closing the game entirely then starting it back up again.

This might be caused by NAT type, as I have found friends with a stricter NAT type harder to join.


#18

this happens pretty rarely to never anymore for me.


#19

Have you checked your nat settings? I don’t own a PS4 but I assume you can adjust or reset them.


#20

yes i did… my nat setting is type 2 and my friends are nat type 2…do i realy need to be type 1 and all of my friend to be type 1 to be able to play online?? If i am alone… i can join multiplayer games… but if i add friends from friends list… someone got kicked… we tryed all combinations of (me inviting them in games) (them invited me)… we just dont know how to play with each others. on my router, i enabled Upnp, disabled firewall, i didn’t put my ps4 in Dmz… why should i be in DMZ to be able to play with friends? if in all my others games… i have 0 problems?

If you suggest me to put my ps4 in Dmz… ill try it. thx for the reply