Star Wars Battlefront II PC help


I enabled DirectX 12 in the menus and now the game wont start. The Beta ends tomorrow and my download speeds are pretty bad, so i was wondering if anyone would know a way around it?



Most of the crash reports seem to be tied to turning on the DirectX 12 rendered in the game’s settings. Since you can’t turn it off the regular way (on account of all the crashes), you’ll need to edit an .ini file. Go to C:\Users\your-username\Documents\STAR WARS Battlefront II Multiplayer Beta\settings. Backup the files before changing anything. Open the boot options or profile options file, and look for a line that says “GstRender.EnableDx12 1” (without the quote marks). Change the value from one to zero and save the file. You should now be able to run the game without a hitch.


You sir, are a fucking legend!



Freaking Origin…


hi all, my name is Lena)) I am a new member here )) thanks for your post , nice to meet you all here, in this web site


hello hi , ola )) nice to meet you heree nice posts ,… interesting