Stage 2: Two friends' game crashes right after splash screens. They are unable to play at all


#1

One of them is an Evolve veteran and had no problems with legacy Evolve (up until a few months ago when he quit playing), the other is a new player. Upon starting the game and before getting to the main menu, their games will crash at some point “.exe stopped working”. They are both sleeping right now so I can’t ask for precise details, but I remember the veteran player doing the following to try to fix it (he’s running Windows 7):

  • Verifying game integrity. 3 times.
  • Backupping game data, deleting it and reinstalling
  • Updating his Nvidia drivers
  • Removing every program from startup in “msconfig” except Steam

The last one was my suggestion, because I used to have the exact same issue on legacy Evolve and through startup program tweaking I found out that a software I used to have that saved printer ink was conflicting with Evolve’s anti-cheat solution. But since he disabled everything, that doesn’t seem to be the issue.

@ArPharazon you helped me with the aforementioned problem so I’m summoning you. If you have any questions for them, please post and I’ll ask them tomorrow.


#2

Those were good suggestions you gave them.

Does the game open a window and display something on it successfully? Like a logo screen? EDIT: I see from your title that they did get that far. Thinking again…


#3

Did they use that same printer ink saving program? It’s possible (though not very likely) that it has other ways of running besides being a startup program. If they use it, have them try uninstalling.

If that’s no good, then we can have them send me dump files. In this case, if it’s the same issue that happened to you, the dump file could only confirm that, and it wouldn’t tell me why. But if it’s something else, the dump might reveal the cause.

In the Steam Library, right click on Evolve, Properties, Local Files tab, and hit “Browse Local Files…”.

Collect error.dmp, Game.log, and kandoC.log. Zip up those files and PM me.

If error.dmp isn’t there, let me know.


#4

No, I’m entirely sure they don’t. It was a very obscure software. Also, I mentioned my previous problem to him and he didn’t say anything about also using it. Will collect those files from them tomorrow.


#5

@ArPharazon my Evolve veteran friend fixed it in the stupidest way possible: he deleted the entire “numeric” Evolve folder located in: “C:\Program Files (x86)\Steam\userdata\34070799\273350”. Yes, that’s exactly the only thing that fixed it!


#6

Oh! There’s a settings file in there that I’ve suggested for some people to delete. But I didn’t think these problems fit the profile, so I didn’t think to mention it here. Great!


#7

Yup, he tried the settings file first and it didn’t fix it, so his “to hell with it!” was very fortuitous indeed.


#8

I’ll remember that!


#9

The new player friend also fixed his issue by deleting the folder!


#10

That’s surprising but welcome news. Thanks!


#11

We’re considering just blowing away all existing userdata for all users. Not sure yet though.


#12

Would we even notice you doing it?


#13

I would expect all your options would revert to defaults. Note, I said we’re thinking about it, nothing is decided. Some people would consider it an inconvenience, and we have to weigh that against the people suffering from buggy old data. Also it would trash any locally built shaders, and we’d need to be sure that the next build really has all the shaders it needs, or people will be back to building shaders again and having crap frame rates.

my head asplode


#14

Ahh I see. I wasn’t sure if it was anything we’d notice or not.

A few default adjustments would be worth the bug fix if it worked. :thumbsup: