Stage 2 : Steam Stuck, Can't Play


#1

So after Evolve finished updating, I couldn’t play it.
All it says is that an update is queued but there I no update to download. Help?


Evolve Stage 2 Fails To Launch
The game isn't starting (Resolved!)
#2

Restart Steam?


#3

You tried just clicking play? That works for me sometimes.


#4

Yeah try to restart and see what happens from there. Keep us updated!


#5

Already tried. Even restarted my computer.


#6

Also every time I click play is says it’s scanning for updates, and then it just sends me to the store page.


#7

Try giving it 10 minutes in case it’s just unpacking the game files or something. The download process doesn’t always communicate every step perfectly I think.


#8

12 minutes and nothing changed. Wait more and eat carrots or do something?


#9

Will it let you Verify Integrity of Game Cache? Or it still insists it needs to update?


#10

Won’t let me verify. greyed out it is.


#11

Is there a “Downloads” button in the bottom center of the Steam window?


#12

Nope. I tried installing a game (and then cancelling) to try and see if that would prompt Evolve to do anything but nope.


#13

I’m googling “Steam stuck” etc., let you know if I come up with anything believable.


#14

You think I should just uninstall and try to reinstall and wait it out?


#15

The Internet seems to say, change your Steam download region.


#16

Did nothing at all when I switched it from Dallas to Detroit and back.


#17

Same for me, can’t even install game on both pc, steam says “scanning for steam games updates”, and refresh store page after.


#18

Could be interference from antivirus program? (LINK)

Check antivirus log, see if it’s quarantining Evolve.exe?


#19

Nope. I think I’ll just uninstall and then see what happens when I reinstall.


#20

Well I uninstalled and that happened. Well I think I’m a bit more screwed than I was, cause now the game Isn’t even installed.