[RESOLVED] Lost Tier 4/Store Shows I Purchased Everything


#1

Like topic says - the store shows I’ve purchased everything - but I have NOT purchased everything. I do however own (or should) Behemoth, and the Season Pass (T4 Hunters). But now when I try to launch into a game I cannot select Torvald/Sunny/Slim/Crow, nor can I play Behemoth, it says I need to purchase them. Something appears to be wrong?

Anybody else seen this before?


Suddenly no access to DLC contents
Dlc got locked
Tier 4 is locked today (PC)
Dlc..not available
Lol Mortal Kombat X's problems are Evolve's Fault!
#2

I seem to be having the same problem.
All the stuff I’ve purchased is definitely still on my hard drive, as I have checked, but I am unable to use it for some reason.


#3

Yep im having same problem something isnt right here!!


#4

OK - whew - I feel better. I mean, boo and all that noise, but still.

Maybe when they fix this they’ll fix Slim so I can finally 2 star Spore :rage:


#5

Same problem here, was going to make a topic on it.


#6

Also just found this problem, thought I was alone. Just lost all tier 4 characters


#7

Last night my internet decided to poop itself in the middle of a match. Today I get on to find all my tier 4 locked. Steam still says I have everything purchased and installed. Anyone have any ideas? I already submitted a ticket but it’ll be ages before it gets looked at.


#8

Its happening to myself amoung many others… shouldnt last long


#9

And now its fixed… I was about to finish up some tier 1 masteries lol.


#10

Hey,

It should have been fixed for now!


#12

I moved 11 posts to an existing topic: Lol Mortal Kombat X’s problems are Evolve’s Fault!


#22

Hey just logged in on xbox :video_game: and none of my skins except gold one or my characters or behemoth are there
If I go to manage game they are all installed
Is it just me as the store is also unavailable
Confused


#23

Problem’s happening on PC too, my friend and boyfriend can’t access T4 hunters or behemoth. Leaving a post here to find the answer.


#24

Having the same issue here. All the skins, Behemoth and T4 hunters are gone…WTF?!?


#25

I should also add that I actually -can- access my T4 hunters ( I dont own the behemoth in the first place ) So I’m led to believe it’s just hitting specific people?


#26

I was going to suggest unlinking then linking your my2k account, but it seems more people are having this issue. I’ll check in a second to see if it has happened to me.


#27

Tried unlinking and it didn’t work…same is happening to me on PS4 but I’m in a game with player controlled slim and torvald right now


#28

I’m having the same problem on PS4, I can’t access any DLC characters :frowning:


#29

Yeah, I believe that solved an older yet very similar issue too.


#30

I’m sure the devs will see people are having issues with accessing content they have payed for and will be right on it. :smile: