[Resolved] Battle cabot update Devastating Bug

I have tried to update the game 3 times since the Battle Cabot update each time my Steam freezes up during validation and crashes Then my PC become unresponsive forced to Cold Boot.

Have done everything but uninstalled and reinstalled at this point since I have poor Download rates (600kp/s)
Can I please get help?

Steam Topic. http://steamcommunity.com/app/273350/discussions/2/343787920141882371/

Six (6) times now no change Uninstalling to reinstall good bye daily login.

9 hours and 75 views later not even 1 person/mod comments on the issue.

And judging by how its seems I’m the only person with the problem I’m going to “assume” that I’m the 1%
that can but swept under the rug.
:frowning:

Have you tried the solutions in this thread?

Sorry none of us saw this sooner, sometimes it’s easy to miss threads.

1 Like

WIsh I had looked harder.
Seems like the Flush might have been the fix but since I’m still downloading after the uninstall I won’t Know.

We have a lot of pinned topics, I think it’s hard to find that one.

Keep me updated!

well the full reinstall worked. So it is able to be played now.

2 Likes

Good to hear! Sorry we didn’t help out sooner!