Replace Challange functionality issue


#1

First of all I’d like to say that i really like the Daily Challenge functionality. The only thing that bothers me a little is that I used the replace challange button yesterday on the periodic challenge and it replaced it with the exact same challenge again. Please make sure that when we replace a challenge we get a random one that is different from the original.

I know this is a very minor issue, but probably very trivial to fix.


#2

I think they fixed this issue this morning.


#3

Ah ok, good to know. I haven’t found the patch notes tbh


#4

I don’t think it was in any patch notes, but I reported it a couple of days ago and today earlier a developer told me I shouldn’t have to worry about it anymore. I will double check.

Edit- He actually just said he was working on it. Whoops.

So I guess it hasn’t been fixed yet, but it will be soon.

If it’s anything to consider though, it was occurring non stop for me until this morning. Now it’s stopped entirely.


#5

Thanks for sharing this info! Sounds good =)
I’ve tried it twice and the first time it worked, the second time it didn’t. The difference was that at the first time i waited quite some time before trying to replace it while the second time i replaced it right after log-in. Maybe the outcome is/was deterministic depending on the current time, hence it worked at the first attempt (because delta-t was high enough for it to change) and didn’t for the second time, because i requested two ‘periodic’ challenges within seconds. I suppose this was never a problem with the non-periodic challenges.