Random Game Lock Up (Fix) Windows (Sry Console)


#1

~First to mention that I use windows 8, but this will probably work for 7 as well~
~Second - This fixed my rare crashes thus far, but it isn’t aimed as a crash fix since it happens for many reasons~

My Issue: I had a consistent issue of random lock-ups during pre/post gameplay (with the occasional during gameplay) that would last upward toward 2 minutes at times since I purchased the game back in March I think it was. It got worse with every update so now I assume the reason is for the data amount it was trying to read from the hard drive. Clearly this is TRS’s fault for making a high quality game :stuck_out_tongue:

Reason: It turns out that when I installed my SSD I didn’t set my system to AHCI on my sata. So it was default IDE. A quick switch in BIOS caused my system to not boot until switching back to IDE due to me not installing the drivers when I installed windows.

Solution: I found a website that listed the steps below to set system in AHCI mode without personally modifying the registry or using weird downloaded programs. It was painless and worked surprisingly well. Instructions I used are below, but the website lists a second method which has a less success rate. Only mentioning it incase this doesn’t work and someone wants to get down an dirty. However, I can’t vouch for its effectiveness, only that it didn’t work for a lot of people. This is why I used the method listed below. Far less invasive as well.

Results: Just to say, so far since setting up as AHCI, I have no lock issues with the game as before after about 2 days of consistent gameplay. My write speeds are above normal specs rated for the EVO 840 and my read speed doubled. Apparently AHCI is allows the SSD to run much more efficiently, but I don’t know the exact details on it.

Instructions to setup AHCI Post-Windows 8 Install:

1.    In search, write cmd, right click it and run it in administrator mode.
2.    Type the following command to enable SafeMode boot:
bcdedit /set {current} safeboot minimal
3.    Restart the computer and boot to the system BIOS. This is normally done by by pressing the delete key during system boot.
4.    Update the ATA Drive setting in the BIOS from ATA Mode to AHCI Mode. Save the setting and restart your computer to boot into Windows.
5.    Windows will boot in SafeMode as per step 2.
6.    Open the command prompt again by following step 1 and run the following command to remove the the SafeMode boot option:
bcdedit /deletevalue {current} safeboot
7.    Restart the computer and boot normally.

No registry editing or anything. Worked perfectly without error for
me. Not sure how? Someone with more knowledge on it would know I guess,
but it works. I pulled the instructions from here:

http://www.ithinkdiff.com/how-to-enable-ahci-in-windows-8-after-installation/

Note: Norton didn’t detect anything funky on this site, but proceed with caution as with anything on the web!

Edit: Just mentioning that until I found this, another temporary solution I had was to play the game on my external USB 3.0 backup drive. Split second lag in the occasional game, but didn’t lock up as before. Pretty sure only 3.0 would be worth trying this on as a last resort since the speed is much greater than USB 2.0 devices.


Time For a Break
(PC) Entire Game/Computer Locks Up for 1 Minute