PSN Loging


#1

An issue has come come up recently and I have contacted support and to am completely blown away with the response, how utterly unacceptable the fix ( current ) is.

When I start Evolve is says it is login to my PSN as me, when I try to start a multi player game, it says it is searching then after a while it says I need to be signed into my PSN account to play ( which I am ).

Now the fix was to delete the game and then install evolve again, no big deal one off and it worked, however the next time I tried to play the game it done it again, so I went through the same process, the update takes ages to install so this is not something I wanted to do every time I played Evolve, now it wont work at all !!!.

The next fix ( from turtle bug ) was to make a new PSN account.

Yeah OK its free as pointed out, but is it just me who see’s the major flaw in this.

  1. I will have to start again from scratch after hours of playing and this will make me disadvantaged in game.
  2. This is a full price retail game, so a bug like this is totally unacceptable, end of story and I don’t care if it something to do with Sony either, this bug isn’t new and should be fixed.
  3. What’s to say the new account wont eventually go the same way?

some people will sit there and say ’ what’s he moaning about? ’ but think about the three points I made above AND that this can happen to ANYONE at ANY TIME.

Fix the damned bug turtle rock or give me my money back and every last penny of it, if you can give me the game I paid for.


#2

Making a new PSN account is unacceptable, especially since DLC and progress are tied to that account.
Even if those weren’t tied to the account, that account is probably linked to all your games and you’d need to login to another account just for Evolve.

I don’t play on PS4 myself but I can understand that this is indeed a big problem and quite bad support.


#3

Myself and @Youngmanr6 had this problem yesterday. I waited a few minutes, closed the game, reset my PS4 and it was sorted fairly quickly. How long have you been trying to get this resolved for?


#4

It started that way, then it wouldn’t login until I delete evolve and then reinstalled the game, now it wont even work with that.

I have had this issue for a while, but its not until the past couple of weeks that its come to head.

Thing is I wouldn’t mind, this generations games seem to be riddled with bugs, so its not entirely a problem with Turtle rock, the problem is they don’t seem to actually want to sort THEIR problem out, but want me to do the hard work and fiddling around at my expense, if they said hold on and were releasing a patch in a couple of weeks and were resolve this issue then I can handle that, but nothing.


#5

Erm, so the developers nor customer service want to make a comment on this.

Great…so its tough luck then for me.


#6

I have encountered the same issue for a week now, little response from 2k support, only solution I was given was to basically turn my ps4 on/off, as if I hadn’t already tried that, any update or solutions on this? thankyou