PS4 - Sign in to psn issue - SOLVED


#1

So for over a month now I have had this problem on ps4. I boot the game up, enter multiplayer, then get kicked back to the main menu with a pop up telling me I need to sign in to psn. It might work after an hour or more of trying, which, as you can imagine, led to me not playing evolve for some time. I had all but given up. Thankfully my wife had not. She went back and forth with 2k support for a couple weeks and finally, thanks to Jason M, we have our solution.

Takes less than a minute to do, and, as an added bonus, solved my problem of not being able to create psn parties!

This is to change the MTU setting on your PS4.

Navigate to [Settings] > [Network].
Here you will find four (4) options, Choose [Set Up Internet Connection].
Now choose either [Use Wi-Fi] or [Use LAN Cable]
If using Wi-Fi – Enter your existing access point password and continue below.
If using LAN – Continue below.
Choose [Custom] on the next screen.
Select your normal settings for IP Address Settings. (Note: If you do not know this setting use [Automatic].
Select your normal settings for DHCP Host Name. (Note: If you do not know this setting use [Do Not Specify].
Select your normal settings for DNS Settings. (Note: If you do not know this setting use [Automatic].
Select [Manual] for MTU Settings.
Press enter to pull up the keypad and enter a new value and press X.
First use the MTU value of 1473.
If the connection test is unsuccessful, try the MTU value of 1450.
Select [Next] to continue.
Select your normal settings for Proxy Server. (Note: If you do not know this setting use [Do Not Use].
Next – [Test Internet Connection]
You will see a value under (PSN Sign-In – Successful) if this process was successful.

If you’ve been having this problem, try this out! Hope it works for everyone!
Happy Hunting!


Not connecting to PSN
Unable to join a multiplayer game
#2

Thank you for this Information. We will test it later.




#3

Did not help. Still can’t multiplay evolve. Every game but that work. Fix it please!!!


#4

Hey it works! Thank you!


#5

You are a life saver, thanks man


#6

As far as I can tell, we’re not familiar with this issue and haven’t come across it in house. The proposed fix listed in this thread points to settings for you PS4. I think your best chance of getting this resolved is to contact the 2K Customer Support to go over it with you step by step and see if there’s something odd with your setup.

I’ll present this info and see if one of the programmers can learn anything more about this.


#7

did not work for me. still have to restart my machine over and over again to get the game to work.


#8

i’m having the exact same issue.