Protocol Error Still persisting


#1

Playing multiple games with friends, doesn’t matter how long I’ve played, I will randomly get booted from the game with “Protocol Error” and when attempting to rejoin some one has immediately replaced me and the lobby is full.

This was happening in beta, this was happening in Alpha. This is still a persistent problem.

The ONLY time I saw some one say they fixed it was by reinstalling, so I’m reinstalling it on my solid state hard drive and hoping for the best. Either way, this is absolutely a game breaking bug, and has ruined my experience of this game.


"protocol error"
#2

Update: Just reinstalled on my solid state drive and still no good. Getting protocol error randomly once again.


#3

I have the same problem too((
but it was ok in alfa and beta.


#4

buddy of mine has this issue, any dev care to comment on it?


#5

Bump. This problem has been happening to me since the Beta. Its terrible and annoying.

I can’t play the game.

Where’s the patch Turtle Rock?! This problem is old old.


#6

Just want to come here and post about the same issue… could’nt play any multiplayer games with my friends so far.

I get in for like 10-20sec. then back at the menu with the Protocol Error…

Hope the devs will figure it out sooner than later…


#7

Friend of mine has the same issue.


#8

I have contacted 2k on this issue as well and they said its my internet and it’s not I checked everything and reinstalled it 3 times and either of the company’s that made this game have tried to fix this problem sooo not fing happy with this and if they don’t fix this probelm I will not be buying there games and I’ll be tell my mates not to buy there games either


#9

same issue. worked fine all last night and through beta.


#10

did they say anything what could be wrong with the internet? firewall ports ipv6?


#11

Yeah fairwall not updated something about IP address opening up your ports looking up your modem and finding what works best for that model so in other ward trying to shift the blame to my internet I don’t no about you guys but I have fiber-optic so it’s deffently not my internet and I have checked everything they told me to do and everything is sweet


#12

Hi have tried many things…
I tried disabling firewalls,etc. 1st game was ok, then, as soon as the next one was loading, I crashed with the Protocol error. I tried reconnecting, got it constantly after.

I have also connected via my mobile phone’s internet access (so, a completely different network, that is not going through home internet)… All seemed good for the first game, then on the second one, same thing.

So this leads me to think it’s not a problem on my end. Unless it’s my computer, but why could it run every other multiplayer games (DOTA, L4D, L4D2, BF,etc…) without any of these kinds of problems?


#13

whats you windows version, firewall, antivirus?


#14

Windows 7.
Simple Windows Firewall, but I have deactivated it during my tests, so no “firewall” per say on the PC itself (whom is pretty much useless anyways since my router provides one).

Windows Security Essentials for anti-virus purpose.

Like I said, I went through my mobile’s internet connection (so I did not used the router, nor internet modem), and still got the same results.


#15

Friend with the issue has the same av
maybe thats whats causing it maybe…


#16

Thanks, I will try disabling it and see how it goes.


#17

friend tested it with no success we seriously need a developer to adress this issue and tell us whats causing it


#18

Same issue here but it appears very random
@MacMan @r00k do you guys know anything about it?


#19

In situations like this there are a lot of things that could go wrong. Anything from a piece of software on the client machine, to the internet connection, to some hop along the way. 2K has a customer service site that they use to collect issues with their games. We get reports for the issues with details from everyone experiencing it correlated and prepared in a way that we are able to digest it. I would highly recommend opening a support case there and include all of the information that you can (model of your modem/gateway, which AV program you use, etc).

It’s always frustrating to feel like you’re getting blown off with an “It’s your internet” response, but there is a very real possibility that is the case and it’s not something that 2K customer service can realistically troubleshoot and support. That being said, if they receive enough reports of this then it will go from being a fringe case that is likely a client side problem to something a little more wide spread that could be a real issue, and they’ll need all of the information they can get from the community to help find the commonality that links all of the cases together. The link is here: http://support.2k.com/hc/en-us/requests/new


#20

Do you guys run multi-monitor setups ?
I have a friend that suggested that it might be because of this. Thoughts?
When I get home, I will try unplugging the others and see how it goes…