Perk Buying Bug

i cant click anything.

I believe this is a known issue associated with a timeout or other failure with the My2K account.
You can probably try restarting your PC?

Restarting worked for me when I encountered this issue.

oh is it really knows issue coz i thought this is some new system or anything to buy perks.
i’ve been playing everyday tho so ofc i turn on and off my PC and i cant really buy anything since.

seems restarting my pc today not working either.

cant wait for the next update or hotfix. fix the megamouth bug too.

Fixed the title and category for you :slight_smile:

1 Like

I had this same issue many times. Try this, it worked for me when Verifying cache files didn’t.

1 Like

haha i really thought it should solved but no.
exit evolve stage 2 delete these 2 files.
ingame again still cant visit stores and buy perks.

and these 2 files still there. seems like automatically create themselves.

well i hope this get patched soon.
EDIT:
UPDATE 2.16 does ny fix this!!!

please i want to buy new perks and buy something at stores!

I get this from time to time. Sometimes the store doesn’t work at all, so it affects all my buys. When this happens I can’t buy anything, not perks, nor skins or characters.

It fixes itself for me.