Performance

There is a big problem with resolutions. I play the game on low res and everything on minimum to get fps that feels comfortable for playing. But the main problem with lowering the res is that it starts the game in not fullscreen, so i need to to change res couple of times, or even restart the game to get it in full screen again.

After the new Behemoth update, i cant get into the game, its just frozen on the screen where is fiery track from a monster, so idk what is going on.

What is your system’s specification? Does it meet the minimum requirements to play the game?

I think yes, i’ve played the game man, i have around 20 hours on it.

Would you mind sharing what those specifications are? Because being able to play the game and actually meeting the requirements are two different things.

Sure, here it is :
OS : Win 10 Pro/64bit
Processor : AMD Athlon II X2 Dual Core 2,8Ghz
RAM : 4GB
GPU : AMD Radeon R7 200 Series

It’s definitely weird what you are having, but I suggest to try some of the troubleshooting steps posted here to see if the issue still persists afterwards:

You mean my config or my problem?

I get stuck here

Have you tried taking your firewall down? What’s your antivirus? Might need to make an exception for the game’s executable.

Well, i havent had problem with Antivirus eariler when i played. But no, i tried shuting down Avast for 10 minutes, and then start up the game and i get stuck on the same screen. Yesterday i could manage to somehow start up the game, but today again i cant…

And its working now, is this random or what the hell is happening…