PC - Various Networking Issues


#1

My PC Spec:
Windows 8.1 64bit
CPU: Core i5-3550
Memory: 8GB Corsair Vengeance DDR3
Graphics: Nvidia GTX970
Mobo: Gigabyte Z77X-UP4-TH

I’m constantly getting networking issues when I try to play as a party. However, my flatmate doesn’t have these issues when joining the same party. (He’s on a core i7 build with an AMD R9 290X)

My issues normally start when searching to fill the final gaps, I will be dropped from the party in my own lobby, however I cannot rejoin as it’s already part of the session I’m in.
This will signal the end of my game for the next hour because from here on out I will not be able to rejoin due to getting “Connection to Host Failed” which sometimes develops into “The user has been Banned” (for the record, I do not have any cheats, hacks, mods etc installed, I enjoy a challenge and I will never make a game easier) which after an hour off the game, will go back to being able to play.

I cannot create a lobby as my friends will then get the same error when trying to connect to me.

I’ve also had it where we will queue as a party of 3, then I will be booted and my slot filled by a random (making a full game).

Other issues that occure less often then the above include
Effectively a disconnect in the game, where everyone runs on the spot, but comms still work, as does text chat. The game has to be alt+f4’d.
“The Connection to your Previouse session has been lost or no longer exists” is a common error as well.

What is getting me with these errors is that within my friends, I’m the one who seems to get it %90 of the time, and my flatmate who is in that group fo friends doesn’t get any of the errors despite being on the same network.