(PC) Entire Game/Computer Locks Up for 1 Minute


#1

Hey guys. I’ve pursued all formal avenues about this issue, so i’m trying to get help here now.

Every once in a while when I play Evolve, the entire game will lock up. My screen will freeze, and all audio stops except for the ambient noise/music and, sometimes, the voice comms. I can SOMETIMES alt+tab, but for the most part this event freezes my entire computer. In the event the game allows me to switch away from Evolve, I cannot open new tabs on Chrome, open new programs, close programs, open Task Manager (Ctrl+Alt+Del does nothing) or shut down the computer. I can’t do anything.

This always happens for almost exactly 50-60 seconds, every time, and then the game will unfreeze and shove me back in where I was, or, more frequently, to the loss screen, because I was killed while frozen.

The official 2K support deal could not find anything wrong with my system after discussing this issue with them for almost a month now. The only thing they could suggest was verifying the cache/files on Steam and reinstalling, which i’ve done many times. Nothing helps.

The weirdest parts of this issue are the whole-system-locking-up deal, the fact that sometimes I can still hear comms, and most curiously, if I happen to have an elite wildlife buff at the time of the freezing, when I unfreeze, the buff has not decayed at all. It will retain its full duration while I am frozen, even if my teammate’s buffs are almost gone/have run out.

I would really appreciate any knowledge anyone has about this, and if they have found a solution to this. So far the only thing i’ve been told is to play the game with Geforce Experience open, but that doesn’t seem to help.

Basic specs:

AMD Vishera FX-8350 (4.0 GHz)
EVGA GTX 980
8GB RAM
500GB SSD

Latest drivers, running Evolve on “Optimized” settings.


#2

I haven’t heard anything similar man.Is every other game running okay?Have you played a lot of hours in others game but this only happens only on Evolve?

Also @MajorLeeHyper


#3

Yes. I play many many other games, notably: Team Fortress 2, World of Warcraft, Mortal Kombat X, Ultra Street Fighter 4, etc etc. This issue doesn’t happen in any other game, not even close. That’s what makes it frustrating. I love this game so much, but this is well and truly the greatest source of frustration I have with it.


#4

Ive had a video on a twitch stream about me having similar issue about the sounds.
the sound slowly starts to stutter and “broooom” and then it becomes high pitched and blows my ears off - a few seconds later theres no sound left except gunfire.

Those ambientsounds in that time just remain to be high pitched really annoying - unlucky twitch removes streams after some days…

but lucky you at least you r not geting bluescreens, ive already had two the game first freezes, the sound remains even voice and for 2 times ive had the BS.

got the same processor
and a MSI GTX 970…


#5

That is unfortunate. I am lucky in that neither the game nor the computer ever crashes completely, but I almost wish it did. It’s like a horrible tease that it comes back EVENTUALLY.


#6

well careful about your wishes ^^. i was about to replace my graphicscard untill ive noticed that such issues and the bluescreens only appear in evolve o.o


#7

uhhh by the way, do you run google chrome while playing evolve? ive seen plenty of people reporting back in the DXGI Error that they use chrome aswell ??


#8

Sometimes I do, whether to run a youtube video/music or I just happened to have it in the background.


#9

hm well u might wanna try that out if appears more often with chrome? not sure but maybe maybe maybe … u know? ^^


#10

I play with chrome as well no problems.


#11

got nvidia card or AMD?


#12

As listed, it’s an Nvidia GTX 980. Brand new top of the line.


#13

i mean wibaki - i guess hes got an AMD ^^.


#14

Well, this bug just happened again and prematurely ended my Evolve night. Just gonna go to bed now, frustrated; was excited for the new update.


#15

Yeah i’m using AMD.

Also what if you uninstall the latest drivers and install the driver that came 2 months ago for Evolve only?

Plus are you playing full screen?Also try with v-sync closed.


#16

I am playing Fullscreen, have tried v sync turned off, and this has been happening since launch, with the old drivers too.


#17

Is your SSD setup as AHCI in BIOS?

Check Here: Random Game Lock Up (Fix) Windows (Sry Console)

I dealt with this for quite some time. Posted my fix sometime last week. No issues since last Monday I think it was when I implemented the above. May or may not help, but hoping it does.


#18

My bios is strange, but I’ve tried your method. I switched the sata mode to ahci. Unfortunately now my computer blue screens on startup. Currently seeing if I can fix it.


#19

I was able to put my computer back to the way it was. I still freeze in Evolve, but at least I can use my computer.


#20

You can’t just switch it from AHCI to IDE - It did the same when I tried to only do the change in BIOS :frowning: You have to use the steps in the thread above. Listing them below:

Instructions to setup AHCI Post-Windows 8 Install:

  1. In search, write cmd, right click it and run it in administrator mode.
  2. Type the following command to enable SafeMode boot:
    bcdedit /set {current} safeboot minimal
  3. Restart the computer and boot to the system BIOS. This is normally done by by pressing the delete key during system boot.
  4. Update the ATA Drive setting in the BIOS from ATA Mode to AHCI Mode. Save the setting and restart your computer to boot into Windows.
  5. Windows will boot in SafeMode as per step 2.
  6. Open the command prompt again by following step 1 and run the following command to remove the the SafeMode boot option:
    bcdedit /deletevalue {current} safeboot
  7. Restart the computer and boot normally.

Its pretty straight forward thankfully. Admin cmd prompt, type command - > Reboot to BIOS and switch to AHCI -> It will auto boot to safemode due to command -> Admin cmd prompt again, type another command to negate the first -> Reboot to normal windows

AHCI drivers are usually installed when first installing windows, so I think booting into Safemode via the method above allows it to install the drivers.