Overwhelmed by gameplay bugs


#1

I don’t even know where to begin.

Is there a single targeted monster ability across three monsters that works more than one time in three? When the game doesn’t hardlock or crash (something no other game has ever done on this system), I usually quit the round due to being very nearly dead by stage 3 after every single thing I’ve attempted failing to function. Yet I had no issues with these abilities in the Big Alpha, few in the Technical test, and a fuckton now. Isn’t that a little backwards?

Goliath:

At least one in three rock throws explodes ‘inside’ the Goliath, due to some invisible or lagged up collision with a thing that isn’t there. No hyperbole, at least one in three, some rounds more than half of my rockthrows act as though the rock is smashing into the monster itself.

Leapsmash: Same issue, in effect - I aim at hunters, indicator is good, but when the leap animation begins, the yellow radius icon and trajectory lines glitch out and flick to some object to my extreme flanks, and I teleport to those locations and smash into them, 30-50 feet from the location I targeted.

Flamebreath: Usually works, but sometimes completely fails to register on targets.

Charge: Usually jams on ‘invisible objects’, and ends, half-way to my target.

Kraken: Lightning - same issue as Goliath, the indicator glitches inside the Kraken and lands behind him, or catches on something to the extreme flanks with a flicker of the indicator.

Mines: Usually stop in mid-air half way to the target, or spawn ‘inside’ the Kraken so I have a big spiky ball on my nose. When they do land on-target they often become stuck inside the terrain and refuse to track any target no matter how close, as though it has no line of sight.

Electrical whatever the fuck it’s called AOE body blast: Not sure why the Kraken even has this, but it usually causes the kraken to rubberband backwards by several feet, permitting the targets to jet straight out.

Vortex: Usually works, but sometimes simply doesn’t register on target at all.

Wraith:

Blast: Usually gets stuck on invisible objects and explodes in mid-air, same as all other targeted abilities.

Abduction: Worst of all, I’ve tested this one ten times in a round and achieved a single successful abduction. When the ability doesn’t simply lag into the nearest wall or stop half-way to the target and attempt to abduct air molecules, it has across seven or eight wraith rounds in the release version to date worked only ONCE. It connects, the target screams, occasionally they take a small amount of damage, but they remain exactly where they were while I zoom backwards hugging empty space to my chest, while costing me a lot of health. Nine times in ten. I checked the stats at the end of that round; Abduction: 1. They screamed, staggered backwards, took around 15% damage, but weren’t ‘taken’ nine times, and only one actually snagged the target.

Nova: Works, when the targets don’t lag-kite and ignore damage as though they’re not really there, or become immortal bots trapped in looping animations while their client is crashing.

Is this just me, or is this game worse than AC: Unity in terms of stability and glitches on release? My disappointment, as a pre-order ‘Monster edition’ player who was impressed by the Alpha, is… Sort of nauseating. If there were a refund available, I’d take it, and re-purchase later on a sale once these issues are resolved.

So, serving partially as a long, whining, detailed complaint, but partially as a tech support request; What in the flying fuck, why me, anyone else, and is there any guess on when these problems will be resolved, or if they’re specific to me, what the hell I can do to resolve them?

I’m running maxed out, perfect performance on a stable system that runs all other current games flawlessly. I average 20-40 ping in competitive multiplayer shooters and download at 5mbps off-peak with a popular local ISP in the UK.

Why does Evolve run like I’m playing an untested alpha at 500 ping?


#2

I’m not sure what is going on for you but my friends and I haven’t seen the issues you are referring to. The issue that I have seen is the occasional shadow glitch which is annoying but bit game breaking. Comparisons to AC:Unity are absolutely not warranted In my experience.


#3

Issue I keep getting as Goliath is sometimes after an auto-attack I run at the speed of sound. Went trolling around the map like this for 20 seconds.


#4

Your shit is broken. Where are you located? What is your internet speed? Sounds like you’re having some extreme latency.


#5

I get that for a second or two at a time, though more often I get the ‘try to eat a corpse, suddenly get thrown 400ft backwards across the map’ thing.


#6

I’m in the UK with a Virgin Media connection that averages, as noted, about 5mbps on download, a decent upload, and 20-40 ping average in your usual online games. I can’t recall the exact stats as they periodically upgrade them in small, meaningless ways for attention ;>


#7

I’m commenting upon its media reception, I’ve yet to play it personally. As a result, this is the buggiest game I’ve played in several years, including a wide variety of early-access titles, and including this very game’s two testing phases I took part in.

Update: Earlier today I played a round at what I’d estimate to have been 300-500 ping, based upon the way all sneak attacks would fail entirely on animals at any range (20+ attempts while hunting), the way enemies would teleport and warp when attacked, and the constant white text warnings that ‘game experience may be impacted’ by poor server performance.

… despite this, I won handily as a wraith and my abductions worked almost perfectly, for the first time since Alpha.

This discourages my theory that there’s a meaningful role being played by network lag in the glitches - they never felt that way, they just feel like the game interface is disagreeing with the location of the mouse, and the game is disagreeing with itself about where my character is standing. I can’t really speculate any further.

I reiterate; no other game I own has any problems.


#8

Honestly it sounds like you’re having horrendous lag problems. I VPN’d from Texas, US to South Korea at one point with similar results. But you could also try verifying/re-installing.


#9

It may come to that, but I’m honestly very skeptical of the issue being on my machine. I shouldn’t even be able to connect to a server if something is that messed up. If I could I’d worry the game was far too open to hacking.

Lag is an option, but if I’m being matched poorly isn’t that the matchmaking at fault? Unsure what I can do about it without input from TR on the subject.

When you played with SK, what was it like - would you mind describing the feel of using your abilities?


#10

It was delayed and caused the sliding around sometimes, but none of my targeters or hitboxes ever broke.


#11

Sounds like you’re experiencing heavy lag.


#12

Like I said, I’ve had serious lag in a match with constant ping warnings and oddly, it performed better than usual. I had major kiting issues with AI wildlife because whenever I swung for them, the hits would miss as though the animal was really much farther away - but my Abduction/Wraith Blast during that round were extremely precise, much better than in any normal round.

Odd stuff.


#13

Never seen any of that… sorry mate.