Opening player menu deletes crates

Type (ie. Gameplay, UI): UI
Character: N/A
Map/Map Location: Menus
Game Mode: All Variants
Platform: PC

Can you tell us the steps to reproduce the issue or what you were doing when the issue occurred?

  1. Buy or earn a crate
  2. Open the profile menu with keyboard shortcut before opening it
  3. The crate you bought or earned deletes itself

@m3teeh this seems like a pretty major glitch - I’ve tested it a few times and it seems to pretty reliably happen. There is a possibility the crate is just opening without me seeing it, but I’m not seeing new content or keys being added/refunded.

I just tried this internally and the game kept my crate every time. :confused: What’s the keyboard shortcut to open the profile menu? I wasn’t aware there was one…

If you give me your Steam ID, I can make sure everything is okay with your crate purchasing and tell you what you got from each one. :smiley:

1 Like

I am using a controller, so I’ll have to double check where it maps, but I have it on the left I think. (Possibly right? One is challenge menu, the other is player menu). If you’re seeing them work on your end, then there’s a good chance is opening something and closing before I can see what it is/what keys are added.

I can’t check my steam ID from where I am now, but I’ll definitely like to get back on that sometime!

Oh, okay! I used a controller and I see the error now.
The game will incorrectly give you a purchase confirmation, but in reality, it doesn’t take your keys, and that is why you do not get a crate. I tried this a number of times and this seems to be the case 100% of the time.

But feel free to give me your Steam ID later so we can be more sure. :smile:

1 Like

That’s good to know! Thank heavens! Does it seem okay with variant crates?