Not able to Evolve as Monster


#1

While playing a game as behemoth on distillery i was not able to evolve even though my Evolve meter being full and having the prompt, when i used it, Behemoth began to rapidly go in and out of the Evolve animation but not starting to evolve.


#2

Did you get a notification that the terrain was not adequate? (example: hugging a wall or something along those lines)


#3

yes, i got it when i first tried then when i moved away from a wall in an open area it began.


#4

Did you just press the evolve button? You have to hold it down to evolve.


#5

but it only gave me the notifcation the first time i tried and not at all during the actually error.


#6

Then you’ve found a legit bug, Let’s hope the devs see this post.

BTW you don’t have to hold down the button.

It might have been caused by the fact that you had the notification at the first try, and that somehow bugged it out


#7

doesnt matter what i did, when the button was pressed it started to rapidly pulse in and out of the evolve animation.


#8

Did the abilities screen ever pop up or did it not even let you get to that point?


#9

It rapidly pulsed in and out of the evolve animation but never evolving.


#10

hmmm ok this sounds like the beginning of another bug we are running into. Thanks for the report we will be looking into this.