Need XBox Help


#1

Hey guys. Lately my XBox has been doing some… weird stuff.

It started with Mortal Kombat. It would get into the loading screen, and would never load. I never even got to the menu. The weird thing is that I was playing it fine the night before.

I said screw it, and went to Evolve, hoping to play with @Raptor. To my surprise, I never got past the sign in screen. Never even got to the menu. I watched the Goliath v. First Tier cinematic about 6 times before I gave up. Tried playing BF4 after, and it still didn’t work. I just tried playing Evolve again, no dice.

I’ve checked my internet connection and I’m fine. I’ve shut down my system, restarted the games, and still nothing I’ve tried has worked. Has this happened to anyone else? If so, what did you do to fix it? I’m really hoping it’s not a problem with my console…


#2
  1. Contact MS Support and ask them. They have never been that great, but the=is is their thing, and they can likely solve it.

  2. Try using the factory reset.


#3

That should be a last resort as it deletes the game and save files.


#4

Yeah sorry, forgot to mention that.


#5

I really don’t like customer support, and I really don’t want to reset my XBone.

If I reset, would it get rid of everything I purchased and all of my things on Evolve? :cry:


#6

If you had a PS4 I would be able to help more but unfortunately you don’t and I don’t have a XBOX One so that sucks. I also believe Sony’s support is better than Microsoft’s from what I hear.


#7

Thanks. -.-


#8

Sorry but by any chance do you know if the XBOX has a safe mode of sorts? It’s basically where you can rebuild the database and stuff like that.


#9

No idea. I should look into it.


#10

That’s usually what support will direct you too if said program exists.


#11

Btw do you play on disc or digital download?


#12

I had the same problem with my digital download version of Evolve (I couldn’t sign in for 3 days) and I contacted support and they weren’t very helpful; they just suggested that I do all of the things I had already told them I tried.

I ended up uninstalling the game and re installing it (which took forever with my mediocre interwebs) and it eventually worked. I needed to restart the system again, sign out of XB live account, start evolve, and then click on my GT account when it popped on and it worked.

I’d try that, I seriously doubt you need to factory reset unless you have a definite hardware issue.


#13

Disc. And, thanks to you telling me to google if I have a safe mode, I learned how to fix it! Thanks @LosSalvatierras

@MidnightRoses, requesting lock! :smile:


#14

I just hard reset it. Hold down the power button on the console for ten seconds. It fixed everything.


#15

Glad I could help :grinning: actually surprised I was able to.


#16

When you turned off your system did it go into like sleep mode or completely off?


#17

Glad you got it sorted, Tate! :slight_smile: