Need help with my PC (CTD on every game)


#1

Earlier today my PC started to crash to the desktop or come up with the full “Windows need to restart” type error for some reason.

It was working fine earlier today and now I can barely go on a game for 30 seconds before it crashes with no errors.

If anyone could help I’d appreciate it


#2

What are your pc specs?


#3

GPU: AMD Radeon R9 380 4GB
CPU: Intel i5-4460 @ 3.2GHz
RAM: 8GB (not sure of the brand etc)
OS: Windows 10

If there’s a way to find out everything else that’d be useful to know so I can tell you the rest suc


#4

Not if it’s crashing before you can do anything.

What version of Windows? And is there any sort of error code?

Lastly, what happened before all this started? Anything of note?


#5

Edited the post to show the OS with the rest of the information to keep it all in one place.

I’ve had two different Windows errors, the only one I can remember was something like “MEMORY_MANAGEMENT”.
The other one was way longer than that and about an hour ago so I’ve forgot it.

Slightly after it started to CTD occasionally, I opened “AMD Gaming Evolved” and it said that none of my games were optimized so I let it optimize them all. It was then that the CTD’s got more frequent and sooner. I reverted the changes but it still seems to continue to CTD the same.


#6

Check this article:


#7

Will do, the restarts didn’t help so I’ll have to try the other solutions but hopefully they’ll work :frowning:


#8

I had a similar problem. You should just check whether this might apply to your system or not:

Potential Memory Crash Fix


#9

What do you mean by “Page file size”?

My set up is exactly like yours, OS on the SSD but majority of games on the HDD


#10

To access the page file setting in Windows 10 you go to the Contol Panel, then System, then click on Advanced System Settings on the left column, Then under the Advanced tab look under Performance and click on Settings, a new window will open, click on the Advanced tab and look where it says Virtual Memory, click on Change and you will be at the settings for the page file. Choose the OS HD and select System Managed Size. The other HDs should be set to no page file. I hope that helps! If this is the problem then changing the settings and restarting the system should resolve it immediately.


#11

I am Having MEMORY_MANAGEMENT problemin My pc.


#12

What are your pc specs and operating system? Did you check out this thread where I discussed my memory problem and the solution? Memory Crashes on a new high end system build (CTD Solved)


#13

You realise this is 6 months old right? :no_mouth:


#14

@Kinjo just posted on it today, so I was responding to him.


#15

Ah my bad, I got a notification so I assumed it was aimed at me


#16

Since the error message is related to the memory of your system, I suggest to follow the instructions mentioned in this Windows forum post here:

http://answers.microsoft.com/en-us/windows/wiki/windows_10-update/memory-problems/21c3f63f-f570-4522-b2ef-ecc7b7ff6461

I hope it helps!


#17

Not gonna lie, I forgot to reply to you.

If you are having the MEMORY_MANAGEMENT problem on multiple games then click the link below and follow the methods on there, pretty sure it solved my problem:


#18

I found its my windows related problem

http://www.deskdecode.com/memory_management-0x0000001a/

but i still get bsod within 2 hours

is that any way to fix this compelely? :frowning:


#19

I FIGURED IT OUT!!! I had the exact same problem where it would crash every time I shutdown/restarted the computer. It was extremely frustrating. And for whatever reason windows 10 wouldn’t record and error report and it would stall at 0% when collecting information. I have an acer travelmate 4670 (I know…a little dated…but she runs like a dream with her SSD). Anyways, it wouldn’t happen in safe mode but it would still happen if I performed a clean start (shut down extra services in msconfig). So I figured it was a hardware issues as opposed to a software issue which would have resolved with a clean start. So I went to device manager and right-click disabled every extra piece of hardware. Hurray!! It worked! Then I started re-enabling hardware until I found the culprit. For me it turned out to be the conexant 56k modem. I probably could have found a more compatible driver on the internet but I haven’t used dial-up for the better part of a decade so I just left it disabled and haven’t had a problem since.
Hope this helps!
p.s. Enabling a single piece of hardware and restarting my computer each time was fairly tedious. It dawned on my afterwards that it would have been much faster to enable half the hardware each time.
Ex:
Disabled hardware 1-20…restart…it works!
Enable hardware 1-10…restart…it still works!..not hardware 1-10 giving me trouble
Enable hardware 11-15…restart…problem is back…must be somewhere between 11-15…but hardware 16-20 is good.
That would have been much faster then restarting the computer EACH TIME! What was I thinking using a linear search algorithm!
Or otherwise try this: http://www.deskdecode.com/memory_management-0x0000001a/


#22