My evolve game won't launch

Hi everyone!
Been playing Evolve since a day or 2, but yesterday it just won’t seem to get past the ‘preparing to launch evolve…’ steam message. I googled it myself and I see lots of people having a similar problem - here is a list what I have tried:

  • Restarting steam
  • Rebooting my computer
  • Verifying cache files
  • Run as admin
  • Using dependency walker to look for missing DLL files(using this guide Preparing to launch Evolve... Then nothing! [SOLVED]) : after adding all missing/corrupted DLL files the program still said there was an error when launching as followed; Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module. Error: Modules with different CPU types were found. Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.
  • Removed and reinstalled DX11 and C++
  • Reinstalled the entire game
  • Unplugged and replugged my powercable (someone suggested it, I don’t know why i even tried)
  • Quit all other background programs that were not steam.

I’m getting pretty pissed and desperate at the same time. Im considering a refund while I still can. Please, please someone help me.

TRS won’t likely be in the office for about 5 hours. But I’ll tag @MajorLeeHyper so that he can try to help when he gets in!

Thank you!

What operating system are you running?
Also, just to rule things out, are you able to launch other games on steam?
Do you have a firmware or anit-virus that’s blocking steam from using those files?

I would try this:
Close all the windows completely(including Steam)
Go to the installation folder of Steam
Look for a folder called AppCache and delete it (make a backup copy though)
Reboot your system and open Steam so it’ll redownload that info

I’m thinking maybe the issue is Steam if you’ve redownloaded the entire game and everything on your computer is up to date.

Im running windows 7 - which is suprising since ive mostly seen people with windows 8 having this problem

Yeah, it’s mostly Windows 8 and Windows 10 I’ve seen people have issues with.
Then 2K doesn’t help them and just tells them to wait until the official release of Windows 10.

It’s just evolve thats has been bugged from all my (steam) games. I’ve tried what you suggested, didnt work either.

Would installing an previous videocard driver help? Ive read it it helped some people with this issue.

Is it an Nvidia card?

I’m not sure, do you have Nvidia?
On my work PC I have Evolve installed, and it’s running Nvidia GeForce GTX 970 on 353.06 with no problems.

Yes I have an nvidia geforce 750Ti

I haven’t been able to play for a month. You think you’re suffering?

Manually installing DLLs sounds dangerous to me, not just to Evolve but to your whole system. It would be so easy to get it wrong. Do you keep your system up to date with Windows Update? Could be a missing redistributable.

Try this:

  1. Create a new user account on your system (Control Panel)
  2. Log on that fresh account and start Steam, it won’t download the game again but you have to give Steam credentials. (Do not run anything as admin in this step ! Do it simple.)
  3. See if the game can start now.

I tried it, didnt work however.

@ArPharazon I seem to be having a problem installing windows service pack 1. some thing blocks it from installing, im trying to figure out how to get this solved.

new plan: reinstalling windows. getting a new cd key soon.

Yes, every day is a suffering :frowning:

1 Like

Wow. Good luck, hope it goes smoothly!