Mouse issue


#1

Im not 100% sure when it started, but I would time this issue after the patch 7.0.

If Im hit mid-air with any ability, my mouse will start doing 360 degrees aggressively.

  • It happens with all the characters

  • It happens in any mode

  • It happens in any map

  • It does it every time Im hit mid-air

  • It didnt happen for first 3-4 months I started playing (august 2015)

  • It doesnt occur in any other game, nor have I changed any settings when it started to occur (not that I can remember anyways)

  • What Ive noticed is that the speed of the spin correlates with power of the ability. Goliath´s rock in the face makes it most aggressive. (lesser hit with rock will result slower spin)

  • I can “counter-shake” the mouse to mitigate the problem and it stops after I counter the momentum for 1-2 secs, otherwise it will stop when I hit the ground.

  • Windows 10, Razer DeathAdder 2013

PS. If I get in for tomorrow´s tournament, you can all laugh at me when it happens. :slight_smile:


#2

Got any hairs stuck in the mouse laser by any chance? Cause I have the Naga 2012 (Old mouse I know), but sometimes a floating cat hair or something gets wedged in there now and then and I can lose control of where I wanna go :stuck_out_tongue:


#3

Well, for you I did double check, not a hair to be found. :slight_smile:

I havent given much of tough to any hardware reasons as it happens only when hit mid-air, only Evolve. Never on the ground.

Its not game-breaking but bit annoying to say the least.

PS. I did also check that I wouldnt be lifting the mouse while physically trying to dodge in my chair


#4

It is a really bizarre thing to happen… I haven’t experienced it myself but maybe there’s someone else around with the Razer Deathadder 2013 around, could maybe double check if it happens to them too. Your Synapse (if you use it) is upto date too, right?


#5

Ill try removing drivers and re-installing them (as they are updated).

Im not all illiterate with computers, but I dont even have an idea how I could pin point the problem to fix it.

Come to think of it, I have changed my DPI. Have to revert that, even though is sounds far fetched


#6

Hmmm…
Heeey @ArPharazon - D’you guys have this mouse at your place, just out of curiousity? Razer Deathadder 2013? :smiley:


#7

Razor Deathadder???


#8

Razer Deathadder. S’a mouse. Why :P?


#9

That is the most cheesiest name I have ever heard…

(No pun intended…because it’s a mouse :stuck_out_tongue: )


#10

No idea. @MrStrategio, does QA have an inventory listing that would answer this?

What is different about this mouse? Does it have rumble or something?


#11

Not a clue really, I figured maybe it -could- be a specific issue with that mouse… I was hoping someone else would show up saying “Yo I have this mouse too and the same thing happens!” but that’s just wishful thinking o.O


#12

hey, you never know. thats how stuff gets refunded :stuck_out_tongue:


#13

This just sounds like the game mechanic where getting hit in mid-air can cause the character to spin until they hit the ground. It’s pretty annoying. It happens to everyone. I don’t think it’s you, just the game.


#14

Sounds about right. Has it always been there? (bcos it felt it started suddenly)


#15

I’m pretty sure I remember it being in the game since the very start, can’t confirm though.


#16

We are aware of this issue, but we haven’t been able to reliably reproduce it on command. It’s probably not based on your hardware.

Do you get this issue everytime you get hit in air? Are you always jetpacking normally or boosting when you get hit? Do you take a specific Perk everytime? Do you use any special settings?


#17

The hit needs to be strong enough. Only Goliath´s rock does it reliably, and I just discovered that Bob´s fissure does the same thing. Like I mentioned above, the spin correlates with the hit´s momentum. So if you are looking to replicate, use Goliath´s rock

Im pretty sure it doent matter whether Im boosting or jetpacking normally. I have to keep an eye on that one.

Im dont think its Perk specific, but I do only use Movement, Jetpack, QuickSwitch, Reload, Capacity with all the characters.

By “special setting” you mean video setting or mouse settings? I have my mouse usb Polling rate at 1000hz (which my mouse supports), DPI Ive tried changing, I have

  • i_mouse_smooth = 0
  • i_mouse_accel = 0
  • r_MotionBlur = 0
  • cl_fov_merc = 90

from autoexec.cfg

W10 mouse acceleration off, Ive calibrated DeathAdder with the mouse surface and tried without it.


Nobody seems to know if this a bug or a feature