[Maybe not a bug?]PC : "low on memory" /memory issues?


#1

Hello everyone,

I did not see this issue into the “known PC bug” tracking topic so I am opening one.

I am experiencing issues with evolve and memory use in windows.
Several times I found a windows pop-up when leaving the game saying that memory was getting low and windows may have to close evolve to prevent data loss.
Yesterday Windows finally get to next step and closed Evolve in the middle of a game with a pop-up saying that memory was too low.
(I apologize for not giving the exact error message, but I am French and so is my Window and its error messages).

Anyway, I think it might come from the game as I have 8Gb of RAM, and never experienced the issue with any other programs (wether games or some heavy ram usage things such as gigapan stiching, where RAM usage exceeds 6 GB…). And I think it is a bug (maybe some kind of memory leak ?) as 8 GB seems extreme for a game.

In case it helps I have win7 64bits, 8Gb of RAM, a GTX 970, I am using the latest nvidia drivers, and as far as I know the virtual memory setting was set to use between 200mo & 2048mo on my main hard drive (meaning the system would have to use more than 10Go of RAM to run out of memory…)
I can provide more information if required.

Evolve is a great game and I would be happy to help solving this issue !


#2

Check that your hard drive that has windows on it has sufficen space to operate properly.


#3

It does, about 40 Go…

I truly believe this is coming from Evolve…


#4

I was originally going to suggests defragging but I’m not sure that would help after reading further!


#5

Is your pagefile turned off if so re-enable it.


#6

I am quite sure it was already turned on. “pagefile” is what I meant by “virtual memory” in my first post : set to use between 200 & 2048 Mo.

Isn’t 8 Go enough anyway, regardless of page file set up ?
I really don’t think the issue is the amount of memory actually available. Otherwise how would people with less RAM do ?
Though I am surprised to be the only one with such issue…

Edit : I will try to play a few games this evening while monitoring Ram use, to see if anything odds can be seen… Does anyone has an idea of how much ram Evolve uses during a game, to have a comparison basis ?


#7

are those the default pagefile settings? if not try to set them to default and try again.


#8

RAM use is a lot more complex than you think. I have 16 GB of RAM, Windows can be reporting a mere 3 GB of RAM, but I’ll start getting this error message because TROLOLOLOL. Chrome is a huge culprit, if you’re leaving it open in the background.

It has to do with Windows reserving but not exactly using RAM. If you want to see how much of your RAM is actually in use, open the Resource Monitor instead of the Task Manager, you’ll see that a lot more of your RAM is being used than you think. Note that this is a good thing - RAM that’s free isn’t being useful!

Back to the question at hand, do you have a pagefile active? Windows is a little dumb and expects a pagefile, even if you limit it to a miniscule amount. Adding a 2 GB pagefile might be enough to resolve the error message.

ETA: D’oh just saw your later post that you have a pagefile. Pity, the main cause of these BS errors is definitely disabling the pagefile. I’d recommend trying setting it to a solid 1 or 2 GB, no dynamic resizing, but if that doesn’t work…

Okay, so then the problem might be a memory leak in an application. I sometimes get this message (even on 16 GB of RAM!) when I leave Chrome running in the background while gaming. These RAM hogs might not even be reported in the Task Manager sometimes, it depends, but you can find these applications in the Resource Monitor.

Seriously, Chrome is a huge resource hog, especially when the GPU process or Flash plugin goes nuts.

I sometimes get this message a lot, but I don’t think I’ve ever gotten it with Evolve.


#9

Try this
bcdedit /set IncreaseUserVA 3072 (change to a higher value)

Use it on cmd


#10

I get this is I leave Firefox open when I play. I have 8GB of RAM, but Firefox (and Chrome) are crazy memory hogs and can easily eat 2GB or more. Windows will throw the “low memory” popup at you if you get below 25% available memory. In the case of 8GB that means it will happen if you have 2GB or less of available memory.

Either set your virtual memory to default (which is System Managed Size) or close out of all running programs before starting the game. Alternatively, you can invest in another 8GB of RAM, but that’s not really a solution, it’s a band-aid fix.

Two things.

First, this is only effective with a 32bit version of Windows. Most people today have moved out of the stone age and are using 64 bit operating systems. In fact, OP mentioned he has a 64bit version of Windows.

Second, this can cause other system instabilities and is, generally, not recommended. The best use of the command is to set up a batch or script to run the command when you start a program (like Evolve) and to set UserVA back to default when the program finishes.

Bottom line, I would strongly recommend against using that.


#11

Thank you all for your help !

I tried to reproduce the issue while monitoring both Ram (using windows performance monitor) and Vram use (using GPU-Z). I played solo mod, in aviary, switching characters and monster between games.

Results are somehow weird to me :

  • I did reproduce the issue (at least up to getting the low memory error pop-up), it occurs during my 2nd game on aviary.
  • I did not see “out of the chart” Ram use from Evolve, it was rather stable around 2.5 Go of ram in game (~2.2 Go when in menu)
  • I did not see crazy Ram use from any other software.
  • When error message pooped-up, I had 36 Mo marked as “reserved/booked” (again, sorry my windows is in french), 4300 Mo used, 1516 Mo “modified”, 1567 Mo “sleeping” and only 773 Mo free (thus the error).
  • My Vram memory usage was close to 3.5 Gb the whole time, being consistent with what my GTX970 can do…

So far my conclusions are :

  • There is no clear evidence incriminating Evolve, despite the error only occuring while I am playing it.
  • Dunvi was quite right

:smile:

I will try to set up a 2Gb pagefile as suggesting, without dynamic resizing, to see if it helps.

However, I continue my digging around steam forums and it turns out I do not seem to be the only one with such issue. I at least found those guys :
Memory issue after 5 games or so
And this one, which could be the more interesting one :
Vram usage causing low memory

Which bring me to a final question : could a lack of Vram cause these error messages ?
Considering my 970 was loaded to 3.5-3.6 Gb, and knowing Nvidia driver is doing “its best” to stay below the 3.5 G memory use (lots of complicated stuff on the internet on the matter)… Could it be the case ?


#12

It’s possible. What graphics settings are you trying to use? I’m not sure how nVidia/Windows handle out-of-VRAM issues. I think it can (don’t know if there’s a setting or under what conditions or anything) start using normal RAM as a backup (which will be slower because it has to stream in the extra data - IO is always slow!), but I think that would show up as “hardware reserved” memory in the system monitor (reserved/booked for you, the orange bar) and yours isn’t very high. (FYI, I’ve only ever seen hardware reserved memory go above 100mb with integrated graphics.) Plus, I don’t know why nVidia would prefer streaming to RAM through the PCIe bus over using the slower last 512mb on the card, either way it’s a slowdown but the PCIe bus is already a huge bottleneck.

If you’re above medium textures, the game sorta demands 4GB of VRAM. You could try bumping to medium - you can probably leave everything else on high settings.

ETA: On second thought, I’m not convinced VRAM overflow would show up as reserved. I have no idea how Windows reports it, it could show up under an nvidia process or even the game process theoretically.


#13

I have 16GB of RAM, a system-managed pagefile (which sets it to nearly 16GB), and I still get this error nearly every time I play… XD

Still occurs even if the game is launched straight after a restart, without anything else running


#14

I cannot say I’m glad to see that I am not the only one facing this issue… But you see what I mean, maybe there is something to be looking into here !

However, I tried a few adjustment and I played several games this evening without any low memory pop-up.
I looked at the performance monitor several times, and I had 0 ram free at some point (everything was either used or “sleeping”), but this did not provoke any error.

Here is what I changed between yesterday and today’s session :

  • I changed the pagefile/ virtual memory setting to a 2048Mo fix size.
  • I changed the PhysX setting in the Nvidia control panel from autoselect (between CPU and GTX970) to GTX970 only. (Just a hint after looking at the internet, I wanted to make sure the dedicated tool was doing the job and not the CPU & general ressources).

I cannot be definitive about it solving the issue, but it looks encouraging. Especially considering I played more game than yesterday when I was trying to reproduce the issue (I did a bit of solo on aviary like yesterday, then about 6-8 games in skirmish multiplayer).

My guess is Windows is having a hard time expending the pagefile when dynamic resizing is enable, but I have no clue why this would happen or show specifically with Evolve…

Finally just a quick word regarding configuration and graphic settings, to give some feedback to Dunvi’s comment :

Yes it does, but it doesn’t seem to be an issue on the 970 and its 3.5 out of 4 Go “limitation”

I have an i5-2500, 8 Go of ram, a GTX 970,my main disk is an SSD (with 2Go pagefile on it), games are installed on a HDD.
In multiplayer everything run smoothly at “very high” setting, stable at 60 fps with Vsync.
In solo things are a bit more choppy and I am in-between 40 and 60 fps (I’m guessing CPU is busy with IA and everything and slows things down a bit).


#15

My game runs fine, and I have a very similar setup to you Paracetamol.
I would check to see if any other programs are using up your ram in the background. (although I seem to have no issues with firefox/qbittorent/mumble/teamspeak/email/tonsofotherstuff open at the same time)

i5-2500k (4.6GHz)
8GB DDR3 1600MHz
EVGA GTX 970
1680x1050
Windows 8.1 64bit

Evolve is fully maxed out and never dips below 60fps.


#16

I have the same issue since i updated my pc hardware (new r9 290) and play on high settings.
Today the game crashed after 5 matches giving this low memory message.

i5 4670k
r9 290
8gb ram


#17

I was not getting the pop-up since I switch the virtual memory setting to a fix 2048 Mo.

Today I forgot firefox in the background (silly me !) and I got the message + crashed my game. However this time I actually get a real error message on top of the low memory pop.
It was saying something about “Memory allocation failed” plus a bunch of numbers but it disappeared too quickly and I did not think about making a screenshot (silly me bis).

Anyway, I am still unsure if there is an issue with the game (or the interaction between Windows and the game). Or if it is just very demanding on RAM, and windows closes it because it is the bigger application (ram-wise) at the moment of memory getting low.

Any thoughts ?


#18

I’m facing the same problem too :frowning:

First few games were running fine on default graphics settings (med). The memory low crashes came after I switched it to high. I reverted back to medium and it runs fine.

I’m running window 8.1 64-bit, 8gb ram with gtx 970


#19

Hello Guys,

It’s been a while, but with GTA 5 coming out I ran into another case of “out of memory” issue, while the system was still far from exceeding my 8 Go (at least 3 Go were only “booked” when the crash occured in GTA 5). Anyway, as I was looking for a fix or any feedback on the internet, I came accross an interesting discussion :
It seems that a lot of people who were having trouble were also using an SSD as system disk, while running the game from a regular HDD. Many of them tried working something out by setting up virtual memory on the SSD. While it was reducing the issue’s occurences, it was not a complete fix.

It was suggested to set-up a virtual memory page file on the regular HDD (the one the game’s installed on) as well. I tested it quickly on GTA 5 and it seems to be working, I was able to play wayyyyyy longer than previously (I actually could play until feeling like stopping ^^).

Now, I did not test it with Evolve, and I have to admit that it has been a while since I had the memory popup while playing Evolve (patchs/ driver updates may have helped) but I feel like it could help some of us.

Let us now if it solve anything on your side :wink: !


#20

I’m ready to call bull on this. Do you have a link to this supposed discussion and solution? I’ve never heard anything of the sort.

Edit:
Are you talking about this: http://support.rockstargames.com/hc/communities/public/questions/203283328-GTA-V-PC-Memory-leak ?

Because the problem isn’t having the pagefile on the SSD, it’s configuration related. Moving it to a mechanical drive will resolve the issue, but it’s kind of a case of throwing the baby out with the bathwater.