Main Menu Multiplayer CTD (Crash to Desktop)

For a few months now I have been suffering from this issue of crashing. Whenever I click the multiplayer button on the main menu, it will attempt to load to the next screen but after a few seconds, ctd. Although, rarely, it will just give an error saying ‘Can’t connect to server’

I believe this all started after patch 3.1.1, which was around May I think. I loaded the game one day after not playing for about a week due to exams. The last time I played it, it was fine, nothing at all wrong. However, I went to click multiplayer, and was met with a crash.

Ever since this it happens every time I try to play, except a few rare times when it works, which is completely random and not consistent whatsoever. No matter what I do, no matter how many patches are released it still crashes. When it does actually work, it’s either not for long as it will meet an imminent crash, or it’s riddled with bugs. Such as not being able to join a party, not finding any matches when there in fact are people online, or, a very strange one, only connecting to the same person every time.

I’m not entirely sure what’s wrong, but I think it might be a network issue of some sort. Though I don’t see that being the case as the game worked for several months before this started. That being said the reason I believe it could be a network issue, is when I try to connect to online in any way, I am only met with errors or crashes. Aside from multiplayer crashing, I’ve noticed the profile refuses to connect. It only gives me errors, like cannot connect to server, or server is unavailable etc. and for what it’s worth, the news feed is always ‘unavailable’.

I want to play this game, I want to play with my friends, I need help finding some sort of fix. Anyone who has any ideas, those of who have perhaps already suffered from this and have fixed it. Whoever who may be of help in any way, please, leave your input.

•Attempted Methods of Fixing
o Verifying Cache
o Redownload and Reinstall Game
o Run game in Admin mode
o Run game in Compatibility mode
o Allowing game in firewall
o Adding extra firewall rules
o Update Graphics Drivers
o Update Directx
o Update .Net Framework
o Changing Resolution
o Some other stuff I can’t remember

•System Specs
o CPU – Intel Core i5 4670k
o GPU – Sapphire Radeon R9 290
o RAM – Corsair Vengeance 8gb
o Motherboard – MSI Z87-G45
o Windows 7 Ultimate 64-bit

Something I think might be worth mentioning. The day the crashes started, for some strange reason the resolution was off. I tried to change it in the menu but it was already 1920x1080, so I switched from full screen to full screen windowed. This fixed it. It’s worth mentioning the next patch released a fix for this problem, but nothing else.

Check this post -

Might be due to memory leaks that @ArPharazon and others are working to plug.

1 Like

I’m afraid not actually, I think OP is correct in that it is somehow network related, for several reasons:

  • The game has just started up, too soon to run out of memory
  • It’s almost impossible to run out of memory on PC, you just sink deeper and deeper into virtual memory until it becomes a living hell
  • Entering the multiplayer menu, it isn’t loading any data to speak of, rather it’s communicating with servers.

I’ll post again if I think of anything relevant, but really I’m not the one to help with this, perhaps @Shaners can call it to the network team’s attention.

3 Likes

Awww, well thanks anyway!

Can you check a few things for me?

  • Is there anything particular about your user name that shows up in game? (ie: peculiar letters, extra long name, etc…)
  • Are you able to get into a solo game?
  • When you ARE able to get into the multiplayer lobby, are you able to invite friends into your party?
  • Please check whether there is a file called micropatch.pak inside of the game folder, and any of the gamedlcXX folders. If there is, try deleting them.
2 Likes

Can I resurrect this thread to say that I’m experiencing the same issue? Occasionally I get into multiplayer but then often CTD as the match loads in.
I would also CTD at the end of a match (if I even made it that far).