Low Frame Rate Bug/Stuttering on high-end PC (GTX 980)


#1

EDIT: Sorry for duplicate post, was trying to link it to the PC Bug Reports for moderator attention.

Like many others with high-end PCs, I’ve had less than satisfactory frame rates when playing Evolve. I’m running an i7-3770K @ 4.4GHz + GTX 980, using an SSD and 1080p 60hz monitor with all drivers up to date, and sometimes when I open the game I get a normal expected performance of around 90-150+ fps like most benchmarks have been showing with my setup. Then there will be other random times when I run the game and the frame rate hovers between 50-60 fps under the same graphical conditions.

The performance I’m about to get becomes evident as soon as the game loads onto the character selection screen, and sometimes it will be just under 60fps, and other times it will be over 150. When it’s under 60fps, it will stay around that and be under that number for the rest of the game.

The curious thing is, when I have a Chrome window open in the background the issue fixes itself and game performance shoots back up. When I close Chrome and have no other windows open but Evolve, performance degrades again, and I can’t press the desktop key or minimize the Evolve application window either unless I force Ctrl+Alt+Del. Then I’ll open a Chrome window, click back into Evolve and see the frame rate go back up from ~50fps to 100 (although I did get some stuttering afterwards and an eventual crash to desktop. This may have something to do with the latest Nvidia drivers 347.52 and the “DXGI_ERROR_DEVICE_HUNG” people have been reporting).

Alternatively instead of a Chrome window I tried opening the Battle.net client in the background and it worked as well to eliminate the frame rate throttling. I’m guessing any application which utilizes the GPU to some extent will help resolve the problem. There are however other hiccups and stutters in the game which I’ve noticed, mainly happens when an event triggers or asset-loading such as the monster evolving, or getting hit by a specific wildlife for the first time…possibly related to the day one 3GB patch that “fixed” long loading times, retiring some textures and assets to pre-load before the game starts. This would make complete sense that now with shorter load times, textures, assets and variable events are being loaded on the fly causing stutters. I wonder whether an option or tweak could be made available to pre-load instead. I’d much rather prefer longer load times than constant hitching.

This made me wonder whether Chrome (or another internet browser like Firefox) is running some kind of script that Evolve isn’t utilizing, such as the full GPU capability. If any of you are getting strangely low frame rates but can’t seem to figure out why it’s sometimes fine and sometimes not, try having an internet browser open in the background and see if it improves anything.

Continuing the discussion from Report your Evolve bugs here:

Continuing the discussion from PC Bug Reporting:


Random hitching on high end pc
SLI frame drops NOT VRAM RELATED!
#2

Interesting to note! And very odd, but computers sometimes are. I have been reading things regarding the GTX 980 and wonder if there is an optimization issue with it, but I thought the update was supposed to fix those. I assume you already updated the dirvers due to your post saying so, I just wish I could help more with this. Keep us posted on the browser being open in the background and if it keeps your frame rates up consistently as compared to not having the browser open.


#3

Update: The GPU usage is completely different between Solo and Multiplayer. In Solo mode I was getting the throttled frame rates of 50-60 UNLESS I had a Chrome window open or any other application that utilized the GPU in some way. In Multiplayer, the GPU was fully utilized on its own and I had no problems with frame rates there, with Evolve as the only application running. There have been other posts on this topic as well with Solo and Multiplayer modes having different levels of performance, and I’m glad I found a temporary workaround.

However, what I’m most concerned about along with others is the random stuttering and hitching during games. This wasn’t present during the alpha and beta and happens regardless of what my graphics settings are so I know it doesn’t have anything to do with VRAM usage. An otherwise perfectly smooth experience marred by these hiccups are extremely jarring and immersion-breaking, especially when Evolve is being marketed as competitive and potential e-sports material. This is a section from the Eurogamer ‘Face-Off’ analysis report of Evolve: “The good news is that there’s a boost to overall frame-rates compared to the previous builds, but there is one concerning issue we hope that Turtle Rock fixes as soon as possible. During gameplay we encounter short pauses that immediately break up the flow of the action, whether we’re exploring the environment or engaging in combat. Frame-time measurements suggest that we’re looking at 300-333ms pauses on both consoles - that’s a third of a second where the game temporarily locks up. It’s hardly a game-breaker, but it’s somewhat disconcerting and never happened in the alpha or beta, which were both tested on the same internet connection.It’s not immediately clear what causes this to happen, since these stalls occur randomly, often when the engine isn’t under form of extraordinary load. Instead, the phenomenon sometimes appears when the game brings up various HUD messages, and often randomly when nothing of note is occurring.”

Would it be possible for you to inform the devs on this issue and see if it’s related to that day one patch which reduced loading times, but at the cost of rendering textures/assets on the fly? The constant stuttering isn’t just happening on the console versions but the PC too. The trade-off is DEFINITELY not worth the sudden drops in performance and it would be nice if we had an option or configuration tweak to allow maps and assets to fully pre-load before a match. Thanks!