Low fps and stuttering on alienware 17


#1

So for whatever reason I am only getting from 8-15 fps on the absolute lowest graphics settings. Any tutorial stutters really bad as well.

System specs:
Processor is i7-4710MQ @ 2.5ghz
GPU is AMD radeon r9 290x
Windows 8.1 64bit

I’ve tried updating drivers, and am currently installing the catalyst software suite from the amd website. I’ve looked everywhere and tried everything I can think of or know how to do. Does anyone have any idea on how to fix this?

EDIT: 7 hours later and I finally fixed it! I finally read enough where I thought my GPU was the problem so I went and downloaded the and catalyst control center and under power solutions changed evolve to optimize performance. I guess for whatever reason it wasn’t using any performance at all? Now I can run at very high graphics settings at 60fps.


#2

Did you check on msi afterburner or whatever else that your GPU is running ?


#3

How do you check that?

Edit: please forgive me if I sound stupid. Its been a long day and I’ve been working on this for 6 hours now.


#4

I’m getting similar issues on my own gaming laptop (Asus G46vw). It has similar specs to your computer. Are you getting any input lag as well?


#5

Yes I was getting input lag. The fix I kept seeing was changing the GPU control center, but everyone who was suggesting that has nvidia. I didn’t realized and had one until I googled it and was playing with the settings there.


#6

Haha yeah I’ve tried all the solutions that people suggested, but nothing has worked for me yet.


#7

Try my ductape fix, it helped me for who knows why.
From bios turn hyperthreading off and test the fps and plese report back if it helps or if it does not.