Logitech Illumination Issue


#1

I mentioned this to the twitter account, but I realized that probably wasn’t the best idea. There should be an option to opt-out of the logitech interaction with the LED. Or a fix for the absence of green. The g110 does not have green, so it can’t do the support color nor the trappers. It just turns off the LEDs, which is annoying in itself. I even, turned off the option that stops games from taking control of the illumination and it still did it. http://i.imgur.com/PnxMC6H.png


#2

Wait is there an option to switch the colors in the mouse based on what class you’re playing? :open_mouth:


#3

Mouse and keyboard, if you are using logitech and have the recent drivers.


#4

I’ve got G502 proteus Core.Can i do that? ;o


#5

Must be a logitech. And have the ability to change the color of the LEDs. I don’t know anything about a g502.


#6

G502 is logitech :smile:

http://support.logitech.com/product/g502-proteus-core-tunable-gaming-mouse

I just don’t know how to make that.I thought it only has Blue leds


#7

And have the ability to change the color of the LEDs. I don’t know anything about a g502. I edited my post, I guess you seen it and replied quickly.


#8

Ah yeah.Anyway thanks i’ll try and see if i can do anything.Thanks for the replies


#9

There is an option in the logitech software to shut off game control of the LED’s.

This annoyed the crap out of me to. Had a G110 which can’t display all the colors so it shut off completely on some hunter classes. Needless to say insanely annoying especially when you had no idea why it was happening. I now have a G910 so that is moot but I am still shutting the option off.

But there is something else that worries me. The in Logitech’s infinite wisdom there is NO WAY to set key colors per application/profile. I have to use a 3rd party app (GoD G910 ColorProfileSwitcher) to do something with the lighting that the logitech software should do natively. Problem is this app emulates a game to switch the colors and the option mentioned above needs to be turned on for it to work. I am not sure of the two programs (Evolve and the color switcher) will bump heads.

Because of this there NEEDS to be an option IN GAME to disable this ‘feature’.


#10

Did you read my post and look at the image, Necosis?


#11

I have a 510 which seems to have all the colours but I don’t see why you want the option to opt out does your keyboard not lighting up for one class make it that big of an issue for you?


#12

Oh no! My response did not solve your problem but confirmed there was someone else who thinks an ingame option to turn it off is needed.

Calm the hell down. You remind me of the people bitching over the 3GB zero day patch and late preloads.


#13

I read the title as "Logitech Illuminati issues.

Help me.


#14

Thank you for reporting this!


#15

Calm the hell down. You remind me of the people bitching over the 3GB zero day patch and late preloads.

You seem to have taken what i said too hard. You should take your own advice.


#16

The issue is it turn off the illumination. And it doesn’t show for TWO classes as stated in the OP. The trapper and the support. Yes, it is annoying. When something messes with something else of mine in a wrong or incomplete way and I don’t have the ability to fix or turn it off…yea. I don’t expect them to get it to work on all devices. In fact, I don’t expect a fix at all. And the really shitty part of it all is no only does disabling game’s ability to control the illumination NOT work, but if you delete the two logitech DLLs that inject this feature, the game will not start.

I felt that I should post this anyways, as I know several people that have this same issue but i fully expect nothing to be done.