Laggy as hell games and low FPS mking me want to delete Evolve

Has anyone else been getting these? The game was running fine a few days ago but now it’s bloody brutal

If it’s got laggy in the last few days then you need to do some checking over your machine and any changes you’ve made to it.

I have made sure that all drivers are up to date and nothing is running in the background

What’re your specs?

I’m playing the game at high settings at 1080p at 60fps on a 4790k/16gb ram/SSD/GTX 760 system and maxxed out settings at 100+ fps at 2560x1080 on a 6700k/16gb/ssd/GTX 1080

I have a i3-4150, GTX 680, Window’s 10 and 16GB RAM

@garratose

I suggest to check out some of the troubleshooting steps mentioned here first:

That said, laggy or low FPS doesn’t mean the game is at fault. There can be many external causes for that.
To give you an example from another person who had low FPS but had his problem fixed: Stage 2: Rly low fps

1 Like

That i3 is your bottleneck. Badly

3 Likes

Download Msi After burner … Moniter gpu, cpu. Etc

You will know what is the issue.

I would assume gtx 680 and I3 outdated and needs to be changed

Game has been running fine using CPUCores and GeForce Experience, but Friday till now it’s been bad

nah gtx 680 is more than enough .

I am playing on gtx 660 on medium 60fps.

I have FX 6300 and not i3 though so there might be problem dunno

GeForce seems to have been known to causes issues. I suggest to disable it and manually change the settings in-game. See if the issue still occurs.

1 Like

Seems fine now, also same settings