In-Game Store isn't Working (Solved)


#1

Trying to buy the following:

  • Behemoth
  • Tiger Goliath
  • Clown fish Wraith
  • Sand Stone or Jade skin

Unfortunately, Steam doesn’t carry any of the skins that I want. It only carries behemoth which I won’t buy without one of his skins, and the in-game store doesn’t work and even caused my game to stay in an infinite loop when I tried to buy the clown fish wraith skin. I had to alt+tab and close it, which Task manager said it was not responding.

Tags: @SlabOMeat @MacMan

EDIT: Tried verifying integrity to no avail. Going to do a reinstall using a different download region since I’ll be working today. Never know if one server has a corrupt copy lol


#2

Solution: Activate the Steam UI I disabled it while trouble shooting something and didn’t reactivate.

I was just able to purchase behemoth and for some reason the Jade skin was available already. It said “purchased” before getting behemoth o.0 Cool beans for me though since I can get another skin :smiley: If I got it through a glitch/bug and you remove it from my account then I won’t be offended or upset :stuck_out_tongue: I’ll just have to legit buy it then.