I get FPS lag although I surpass recommended settings by far

stage2
pc

#1

Hello, I am fairly new to these forums, so I hope I don’t put it in the wrong category.

I just downloaded this game 1 week ago, it is absolutely amazing, but there’s 1 thing that’s been bugging me. I cannot run on any higher than medium settings although, I surpass the recommended settings by far.

Intel Core i5-4460 3.20GHz
8GB RAM
Nvidia GTX 960.

My friend has a way worse system than mine, and he runs on “high” settings. Is there any reason for this ? Have I messed up in game a setting by accident or something ?


#2

What is your driver version?
My younger brother which uses my old GTX960 is playing the game fine with everything maxed out.


#3

It’s 355.82


#4

Where did you get those numbers? XD
The latest driver version is 372.54
try downloading the latest driver in geforce.com


#5

I said 355.82, i’ll download latest and see if it fixes


#6

you typed 10...* something earlier
but yeah try updating driver


#7

When updating the Driver, does the old one get uninstalled automatically ?


#8

yeah just click on manual and then check the clean install


#9

Alright, so, it helped alot, but when I do “very high” settings it reaches max 55 FPS and avarage of 50. Never 60. Is that with your brother’s too ?


#10

Try turning off Vsync, hmmm but I don’t know maybe because I overclocked my brother’s gpu it runs from 55-75ish fps.


#11

With what program did you overclock it, and to what did you boost the Core Clock / Memory clock ? when I overclock mine I don’t really see much difference other than 2-3FPS


#12

MSI afterburner,
+0.100v powerlimit to 108%
+175 Core Clock
+450 Memory Clock
for me this is kind of mild overclock
my temp doesn’t go up to 60degrees which makes gpu fan stay 0rpm


#13

I am experiencing the same. Sometimes the game drops down to 30-50 frames for a minute. It’s really weird.

They added so many new animations but I don’t think they had time to look at the game’s performance yet. I think they said after August they have time to look at that.


#14

If I overclock it that much my game crashes, I just tried it :-/ idk why.


#15

The problem that I have isn’t FPS drops, it is just not the FPS I should be getting with my system.


#16

10 charrrrrrrrs


#17

This is MSI GTX960 4G gaming, try googling your gpu name and find the suitable stable overclock if you want, be sure your power supply can handle overclocking.


#18

Yeah, I have same one but the 2G version


#19

Try lowering the shadow and use fxaa only or better yet turn off AA


#20

Meh, guess i’ll just stick with “high” settings since I don’t want to have anything below 60 FPS.

Thanks for the help.