How to change Evolve resolution through .cfg/.ini?


#1

I need some help with either a way to change the aspect ratio or the resolution through files as I can’t access anything through the in game menu as they are oversized and only their borders are clickable.


#2

Ideally is there a command or a way to change the game’s aspect ratio? I have Nvidia surround enabled and I can’t find anything in the game’s files regarding either the aspect ratio or the resolution @MacMan


#3

From this : http://steamcommunity.com/sharedfiles/filedetails/?id=390390244

At first, this guide was build for users who use 21/9 monitors. So put your resolution (I guess it’s 1920x1080) not the 2560x1440.

Here it is : (only step 3 could fix your issue I think. )

Step 3- Use Notepad to open system.cfg in C:\Steam\SteamApps\common\EvolveGame
C:\Steam\SteamApps\common\EvolveGame\system.cfg

r_height = 1080
r_width = 1920


#4

Anyone know of a way to force the actual aspect ratio?

I am a happy Eyefinity user but this game does not play nice UI wise with ultra wide, while yes the menus and things did get patched the in game HUD and map is terrible in ultra wide.

Before the widescreen fix patch (alpha up to a week or so ago) and post widescreen patch fix (up till the arena mode patch) I have used Steam Launch options and the config.sys edit to force the game into 1920 x 1200 (panels default resolution) which rendered the game onto each monitor. Yes I had three monitors showing the same image but it was not a huge deal (other games do this such as DOTA).

This did let me play at much higher graphical settings, keep my display group (3x1) and seamlessly go in and out of the game / normal functions with no delay.

However since the Arena patch (not positive but in the last 1.5 to 2 weeks) something changed, to where those settings now only force the actual resolution so it stretches and looks terrible. I can again go into full 5760 x 1200 and display the game well but the HUD looks horrible.

Is there a way to set the config to force an aspect ratio? I believe that this should kick the game into thinking I only have one monitor again and sending the image out to each monitor. Just a hassle to flip out of my display group and back into it for one game. Gotta be a setting out there somewhere.

Unless they want to patch in an option for that :slight_smile: Or let windowed (border-less) mode kick out to that. Windowed forces me down to 1680 x 1050, and the border less option does keep the 1920 resolution, but stretches it across all panels instead of actually displaying within 1920 pixels.

Thanks!


#5

The Arena patch has a bug which makes the game fail to set certain resolutions properly on certain PCs. We will issue a new patch soon with a fix for this. Then it should go back to working the way it used to.


#6

Well then, thank you for the prompt answer and information! :slight_smile:


#7

I cannot find the r_height or r_width do i have to put it in myself somewhere?

I actually need to make my res lower than 800-600, but is there any other hidden options in system cfg that could help run my game better, like particles not as good or something, I need to either turn my res to 640-400 or turn something down in system cfg cus i can’t find that r_height stuff so i am hoping this is something else i can do

I tried just adding it in but it didn’t work


#8

Before attempting something like that, are you running in graphics quality Minimum yet?


#9

yes indeed i did I did automatically my laptop needs it


#10

yes i am running at min settings


#11

Ok. I will tell you how to do it, but keep in mind this is not supported, and I can’t guarantee it will help you at all. It may be that your computer is below min spec (store page, see System Requirements) and that it’s just not capable of running the game at an acceptable frame rate.

Edit this file in a text editor:

C:\Program Files (x86)\Steam\userdata\xxxxxxxx\273350\local\USER\Profiles\default\settings.xml

You’ll need to replace “xxxxxxxx” with your Steam ID, that’ll probably be obvious. May need to modify as needed if you’ve installed Steam somewhere else.

Set these lines to 0 (and make sure they exist):

	<Attr name="settings/fullscreen" value="0"/>
	<Attr name="settings/fullscreenwindowed" value="0"/>

Set these lines to whatever values you deem appropriate:

	<Attr name="settings/screenresheight" value="1600"/>
	<Attr name="settings/screenreswidth" value="2560"/>

I’ve done this to create large nonstandard window sizes. Have not tried small one, but I’d expect it to work. But the result in game may not be good – again, this is unsupported.


#12

what do you mean by not supported?
like it could destroy my computer or that it’ll look bad?


#13

Also, be sure your laptop knows you want to use a proper graphics card, not integrated graphics. Asus laptops in particular often need to be told explicitly.


#14

Look bad. Won’t destroy your computer. Could make the game unplayable, but if you can’t figure out how to fix it, you can always just delete settings.xml and the game will replace it with defaults.


#15

when i opened userdata two things came up


#16

folders with random numbers, also i want to keep it in full screen will it stay in full screen?


#17

when i open userdata it just comes up with two folders with random numbers nothing with my username


#18

how do i do this? i dunno if i have a graphics card


#19

No, in full screen you must use the options menu to choose resolutions that are offered by your video card. You can’t pick just any arbitrary resolution in full screen, sorry.

Pick one of the random numbers and see which one has a 273350 inside it, then proceed accordingly.


#20

I forget, I don’t have an Asus laptop (or any kind of laptop) here. If you have an Nvidia card, there’ll be some sort of Nvidia control panel.