Horrible performance on a GTX 760 2G? [SOLVED]

pc

#1

So I have a GTX 760 2G an Intel Core i5-4460 and 8 GB of ram and I shouldn’t be getting such bad performance. I have tried lowering the settings but it just keeps stuttering all the time making the game unplayable. I am getting solid 60fps most of the time but the game just keeps stuttering. Is this my fault? Is the card just bad? Because I’m sure it meets the recommended requirements and kinda surpasses them.


#2

Can you share your full specs please?


#3

CPU - Intel Core i5-4460 3.2 GHz
GPU - Msi Nvidia GeForce GTX 760 OC 2GB GDDR5
RAM - 8GB DDR3
OS - Windows 10 Pro 64bit


#4

I believe it’s a shader issue, the more you play the better it should get.


#5

Hmm. Well thanks for the fast reply hopefully it gets better!


#6

I believe they’re working on a fix for a future patch, but for now this will hopefully help. Raise your settings though, it should help.


#7

yea i get the stuttering in the beginning of the game but it goes away after a few moments when the match started, seconds after landing from the drop, but it always happends in every game i play. the rest of the game is smooth as butter for me tho.
A8 - 6600k @ 4.6 gig
R9 285 Itx compact oc 2 gig @ 1065 MHz
8 gig ram @ 2300 MHz
very high settings


#8

Okay so I have played for a while now and things have somehow gotten worse. I am baffled at how this can happen. I tried what you suggested I bumped up the shaders to Very High and at the beginning it didn’t stutter at all but it did lower my FPS by a lot and I was back at 30 fps. After a few games the stutter came back and it was really bad with a frame rate between 20-30 I was barely even running the game. I tried every settings configuration but the game didn’t seem to run like it did before. The most FPS I can get is 40 by lowering the settings to minimum. I even tried to lower my resolution getting only about 50 fps at 1280x720. I don’t even know anymore :frowning:


#9

Have you downloaded the latest patch?


#10

Yes I have


#11

Try this fix. It will delete the shader cache.


#12

Will try this one!


#13

Sadly this didn’t seem to work. Tried it out for the duration of 3 rounds and fps and stuttering are still really bad.
EDIT Changing the settings doesn’t affect the fps or the stutter so I don’t think it’s my computer on that part.


#14

Okay so I have managed to make it run at a constant 60 fps with a few stutters here and there but I’m sure that will get cleaned up after I play some more. So the first and major thing was probably that I didn’t have the latest Nvidia drivers so I went ahead and updated those, next I went to the Nvidia Control Panel and made sure Power Management Mode was set to Prefer Maximum Performance and that helped a lot. I tried to disable every program that was interfering with the game and made sure it was set to High Priority in the Task Manager. That fixed up the FPS issues for me. I want to thank you all for trying to help me although in the end it ended up an ameteur mistake by me :smiley:


Not best PC but played before patch, after I almost can't
Sudden Frame Drops on PC