Haven't been able to play all day due to this


#1

Hello awesome people of Turtlerock! So I’ve been a raving fun since info of Evolve was released and am a loyal fan still. With your recent release of the new hunters and Monster I was able to play yesterday with no issues. Today when I got home from work I started up Evolve and wanted to hunt! Well, I never got to. Every time I would load/join a game it would be black and I would see some commentary from Hunters and then this would happen http://xboxclips.com/seasickwhale those videos show what happened to me again and again and again. I never got into a game. If you need more information let me know and I will do what I can or if you can share some insight on how to fix this, that would be appreciated. I love the game and always will! I just don’t want this to ruin it for me.

Thank you!


#2

Damn, and I thought that I had problems. Have you tried turning it off and back on again? :stuck_out_tongue_closed_eyes: But seriously, have you?


#3

Yes, yes I have hahaha multiple times. Even doing a hard reset of my Xbox did nothing.


#4

Have you tried hitting it with a hammer multiple times as hard as you could. :stuck_out_tongue_closed_eyes: Honestly though, I would think this is a connection problem more than anything else. You might want to try restarting your router and testing re-testing your xbox live connection but if that still fails uninstall and re-install evolve and the updates and hope for the best.


#5

Have you submitted a ticket with 2K Support?


#6

Does a medieval sword work? I’ve done the restarting of my router and whatnot and still nothing. Un-installing and re-installing was last on my list.


#7

No I have not. But thank you for the link Chloe! I will do so now.