Getting stuck in the stage up screen

pc

#1

I apologize if this has already been stated as a bug or commented on but i didn’t see any as a briefly ran through the Bugs posts. So i was playing a match as wraith and it seemed totally normal except that i had an abnormally high ping, around 230 or so. Didn’t think anything of it other than its gonna be laggy which is fine. I go through, eat until I’m evolve ready, then engage the hunters and after i run away and try to stage up to 2. Now I’ve done the Decoy evolve thing before and it hasn’t ever froze me in the stage up screen, but wraith did keep cutting her evolve animation, and eventually she always goes through with it and it lets me pick my abilities and were good. But this time it stopped me on the ability select screen, and i tried everything i could to fix it, but ultimately they were going to kill me, which resulted in my 4th loss because of either the game freezing or a bug that breaks the game. I’m fine with losses but when they’re because of bugs its a little discouraging. Anyways thanks for reading guys, and i hope this hasn’t happened to anyone else!


#2

This is a known issue and we are working on getting a fix for this. The info you put in is very helpful and goes with a theory I have on this so thank you very much for adding all of that.


#3

@dysa72

I believe pressing Right mouse button (smell) unstucked Monster.


#4

Well i tried everything, every possible action you could do and i was still stuck, but if it happens again before the possible patch ill give it a shot, thanks man :slight_smile:


#5

No problem man , it was 100% working in last patch so it also should work in this, good luck ^.^