Game stuttering /crashing


#1

Just picked up the game this weekend. Also picked up a gtx 960 suoerclocked. Game runs fine on high settings with 50+ frames but will randomly stutter randomly. This is the only game this does this, I have maxed out just about every other game with zero problems. I have the most recent drivers which say they are optimized for evolve. My guess would be maybe the drivers are bad? The game has also crashed 3 times with some error message about cryengine. If the settings were too high wouldn’t the game just have a low fps overall? Like I said it will sit at a steady fps and lag/stutter. Anyone else having any of these issues? The damn card is straight out of the box so I doubt it’s that.


#2

Those have been my issues in addition to crashing my whole PC upon launch. When I do get it to launch maxed out it stays above 60 FPS pretty well but will drop down to 30 FPS or so often. Even on Medium settings it stutters bad. Low not as bad but still drops. All during monster fights mostly but even just running around. I have an i5 4690k and R290 with 4 GB VRAM for gods sakes so I can’t imagine it’s that. Not seeing too many people complain about it though so I was starting to wonder if it was just me. Honestly I’ve been obsessed with trying to get this game to run well. I built my whole PC in preparation for this game. So bummed. Of course I have the latest drivers and all. Don’t think AMD has done any optimization for this game yet anyways.


#3

I’ve tried lowering the settings as well but no dice. Most of the drops are with the monster but this card is more than capable of running this game. I also have an i5 2320 which is a little old but still a quad core at 3.0ghz.just anoying


#4

Same here, decent frame rate initially but slowly degrades. I exchanged my asus 960 for an evga 960 thinking it may have been defective but still have the same issue…


#5

I’ve come to the conclusion it’s either the drivers or just the game itself. I can run Titanfall, dying light, smite and any other game I’ve tried completely maxed out with 60 fps yet get drops in this game on medium. No big deal just have to wait for a fix, but I’m glad to see its a common thing so it should be resolved.