Game is really bright?

Hello again , i have a bug where my game is so damn bright that i can hardly see anything … i already did set the gamma to low and the shadows up and still it is so damn bright

there is a screen of my game :confused: maps with snow are insane … cant play them at all

Wow. Please see the self help post first, particularly Verify Integrity, possibly see User Data section on that topic if VI does not work.


so i tried the link you did post me … at it still dosent work , i did upgrade my drivers , DirectX and everything else but the sky is still so damn bright , i adjusted the gamma in the game and it dosent work , but some time if i played monster the sky was ok but as a hunter it is always that bright

Hope some one here might know how to help me

A friend of mine also has this. Hoping to hear a little something more to hopefully help him out.

did you delete the user data?

i did delete all local files and installed the game new , and it still didnt help , i tried everything i could come up with so yea … @Bubbles

try to reinstall directx

1 Like

Please make sure your graphics card settings (e.g. on Nvidia control panel) are at defaults. Don’t use Geforce Experience “optimize game” – we believe it is outdated and will break your game.

1 Like

I have the exact same problem! As soon as I jump out the aircraft everything turns totally bright and can hardly see where I’m going?

I have nvidia MSI 970 4gb gaming card, the latest nvidia drivers and haven’t changed a thing before this issue?? Done everything as advised earlier but same problem? Played the game with absolutely no problems before the patch?

So recently I have this bug, that as soon as I jump out the aircraft in the beginning of the game, everything turns totally bright, like the brightness/contrast is out of control? It’s also more laggy than normal?

I have played with absolutely no problems what so ever, and haven’t change a single thing since this happened?

I have then tried every advice given, even re-installed game, new/older Nvidia drivers, deleted userdata, verified game cache, reinstalled directX etc. etc. Nothing did any help :frowning:

I have a Nvidia GTX MSI 970 gaming 4gb card, 16gb 1600Mhz ram, MSI gaming 970 motherboard, 750W Thermaltake PSU

As written, I did not change a thing from playing perfect and now suddenly this annoying brightness problem? I would love to hear from others with similar problem! Thanks :slight_smile:


The Hunters have lost, Monsters set fire to Shear.

I have the same problem, I downloaded the game, played the tutorials and they were fine but when I went into the ‘Hunt’ game mode and played as hunters this happened. I dunno why, is there a fix yet? I think its something to do with the new effects that make the game brighter compared to old evolve. I had this for a week because that’s when I first downloaded the game.

Have you tried to verify the game cache integrity and update the drivers?

Mind posting your specs too?

Yea i tried doing the things above and didn’t work, the only thing I did not do is reinstall the game because it takes quite a long time for it to download on my internet. image
I hope thats good enough for my specs

Can you try to exit Steam completely, then close/exit the GTX experience app, then reopen steam and Evolve?

My Ge Force Exp. app isn’t working dunno why, so its already closed, it had problems with downloading new updates and stuff so i no longer use it, thats just a old screen shot that i use instead of typing my specs out, and I will try restarting steam again, i don’t think it will work though.

Ahh, I was wondering if that app was the issue.

Can you let me know what fixes you have already tried?

I already tried:
-Verifying the Integrity of the Game Cache
-Updating DirectX, although already had the latest version.
-Lowering my gamma as low as it can go, although I didn’t think that it would work anyway (It didn’t)

If i remember some more ill edit the post but it believe these are the ones i used so far, basically the ones above.

Did you also update VcRedistr?

Try it just in case.

Also, it’s a long shot but you can try this too.