Fixed this game TRS (Resolved)

On my way to work, I’ll try to think of something. It’s a strange case.

1 Like

Barring any other suggestions I would try rolling back one driver version to see if it’s a combination of one of the last two Evolve Stage 2 updates and video drivers, which seem to have been updated beginning of this month. just before the 2.13 game update?

I don’t know if you’re a daily player or once a week, but it’s possible an update to game and drivers could have caused it two weeks ago and you’re playing more now and it just came to a point?

What graphics settings are you using in Evolve’s graphics options? May want to also check out Nvidia’s control panel, see if there are any strange options set there.

1 Like

I had trouble with my fps after the update before last, a full system restart after rolling back my drivers sorted it. Not to say you’ve not tried it, but have you restarted your computer?

1 Like

Also everything seems to be fine on the Nvidia control panel

Use to play everything on max, but started getting CryEngine Error so now i use GeForce Experience game optimization

I have tried everything up to this point

That right there… don’t do that. At least, try using our regular video options. I don’t believe Nvidia’s options work with Stage 2. I’ve heard other people having problems with them. That stuff was not written by us and we don’t test with it.

Try setting to High instead. If that doesn’t work, delete your User Data and then set the options again, using our Main Menu, not Nvidia.

3 Likes

I’ll give it a shot

1 Like

It seems to be working ok now…so fingers crossed, also thanks everyone

3 Likes

Game is still running fine, but for some reason i keep thinking that the issues are there, but really there are not and has lowered my confidence playing this game

Maybe if you lower your graphics options another notch, it might boost your FPS a bit and make the game feel better to you. Or, take a day or two off from the game, give something else a spin, then come back refreshed?

3 Likes

I’m getting 60 FPS

Might need a bit breather from all videogames and recharge the batteries

1 Like