Fix the disconnects or let me rejoin games

I am pretty salty that I get random disconnects at any stage of the game:

  • 1-2 x from the lobby while matchmaking
  • 2x during “Waiting for players” black load screen (fixed this by restarting the game, has not happened since)
  • 2-3x during drop or very early in the game.
  • 1-2x during a match

I wouldn’t mind most of those if there was an option to rejoin the game. When I click on my friend on the Steam FL i cannot join him. When i click “Game Info” it says that he is not currently playing anything, even though it lists him as playing Evolve and he is telling me that he is still in the game. Conversly he cannot use Steam to invite me to the game.

ONE TIME my pc crashed, i think it was my GFX drivers, and I had to reboot. Again he could not invite me. But for some reason after 1-2 minutes he could. I rejoined a game I had DC’ed from, but I think that was Hunt. I have never rejoined a Ranked game, ever. And it pisses me off.

I always get losses added to my Ranking, sometimes even 2 per game. This is very inconsistent. And yesterday I got 4 losses while only playing 2 matches. It took me all day to recover my rank. It kills Ranked for me.

/edit: I just want to say that I have a very stable broadband internet connection, do not download or stream while playing. It only happens in Evolve and I know others who suffer from disconnects and getting random amounts of losses added. Especially the random losses (Some times I log in and have 2 losses more than I should) is aggravating.

bump! what is this? i keep getting disconnects and then lossed credited. i don’t know what to do.

Hello @l2evolve

I’m sorry that you are experiencing a lot of disconnects and suggest therefore to try the troubleshooting steps mentioned here to see if it fixes the issue:

Let us know how it goes so we can help you further!

thanks for the reply.

sadly nothing in that post helps me. I do not have any issues with the game unless a DC occurs (which happens about once every 10 games, mostly during central european daytime 12 to 22 CET. Today I had a disconnect halfway through a game. The next game my friend (who i play with every day) disconnected. In the first case, the entire game ended in the second case only my friend DC’ed and we were able to finish the match. However we lost of course, because we had a bot medic and i could not re-invite my friend via steam. In both cases we got losses added, even though it was not our fault.

This is really killing the game because I can never be sure if the game I play will end with 5 players. It also ruins my rank. It would not be as annoying in Hunt, but when you get a loss for it, it becomes increasinlgy agitating.

I have a 200 Mbit cable internet connection. I usually have no downloads or other internet activity running. I play with a ~30 MS ping in most cases. I highly doubt that the issue is with my IPS/Connection.

Have you verified your game cache through Steam?

yes. i just did that. 100% verified.

Ah, so it didn’t grab any new files? :confused:

That’s odd. because others have tried the troubleshooting steps and it worked for them:

That said, the issue can still be related to your connection and is therefore still advisable to try any troubleshooting steps. Your up and download speed isn’t the only thing that determines a connection. Things like your NAT type, having the correct PORTS opened, firewall issues, whether or not UPnP is enabled, possible interference due to background program activity (such as your antivirus), etc…

it did not. no. also if the game does not crash i have absolutely 0 issues. it runs smoothely and all. i get a good ping and such. just occasionally it decides to drop me or others out of the game leading to a loss.

well i had all those installed by other games before. i did as was posted and repaired the installations. i cannot recreate the disconnect on purpose so i cannot say if it helped.

if i had bad port/firewall settings would i not be unable to play in general. how is it that i only dc occasionally? i have upnp disabled in my modem.