Finding a match


#1

'm having one consistent problem now what the problem is is when I try to go online to find a match on the Xbox one sometimes I will wait upwards of 20 minutes and still not find a match to go into this is were held true for both skirmish and excavation online now I was wondering if this is a problem and I’ve tried on both a university connection and my home wifi connection one which is open that the other which is strict NAT


#2

It seems to be wonky at times. I just hitt he home button and quit out of evolve and relaunch. Even hard resetting the xbox helps


#3

as of now it’s been 15 minutes since I tried searching for a match I’m going to try what you suggested of a hard reset I’ll keep this forum updated but essentially I’m doing this in real time if anyone’s on the Xbox one would like to play with me its online now just go ahead and message me I’ll probably accept it


#4

Both my brother and I are also having this issue.
Cannot find any matches. Most annoying part is the issue that our beta progress didn’t carry over so this is all bad start to a great game : /