Failed Savage skin purchases (PC)


#1

I’ve gone to support already about this issue but I wanted to see if anyone else has had this, and if maybe we could collect some information to hopefully get the issue fixed sooner.

So, the issue: On PC, I purchased the Savage Kraken and Savage Wraith skins. However, when I went to use the skins, they were not there. Going back to the store shows that they are purchasable again. The money has been deducted from my Steam wallet, so the purchase did go through.

This is different, however, from the other disappearing skins issue in which the whole store says “purchased” for everything, including things you haven’t purchased. That issue is usually solved by deleting the cache.m2k file and restarting Evolve, or reinstalling the game. I have tried both of those solutions and nothing has worked. It seems that Steam is not registering the fact that I have purchased these skins, as when I go to the DLC tab they are not there. However, they show up on my purchase history.

I have a video showing this “in action” so to speak: https://www.youtube.com/watch?v=_oGr7RB7bNU

Has anyone else encountered this?

Please, if you have purchased the skins either successfully or unsuccessfully (PC only), can you do a quick look for me at your DLC (Library -> Evolve -> Properties -> DLC tab) and see if the Savage Kraken or Wraith skins are listed there?

Thank you all for your time / help.


#2

Just to be sure, delete the cache file again. It fixed it for me deleting it twice this one time when I was missing all my purchased skins.

If that doesn’t work, you may need to send a ticket to 2K.


#3

@THISaint may be able to help you.


#4

Hey,

It might be a part of the issue that 2K forgot putting up the skins in the actual Steam store itself. I’ll try contacting Tom from 2K if he knows what’s up or when the skins will be available.

Meanwhile, visit this link and check the latest transactions, there might be a Refund available.


#5

Hey, some extra helpful info here for when you do contact 2K -

I tried your solution from another thread to go to the DLC tab, uncheck everything, and launch the game. I launched the game and it couldn’t connect to My2K, so I couldn’t access the store or anything. I launched a quick-play solo game and the Savage skins were there.

I felt like this is an odd fix and I wanted to make sure things will stay this way, so I exited and restarted Evolve. This time, it is able to connect to My2K. You can imagine where this is going… I started another quick game and the skins are gone.

It seems the issue lies somewhere in the connection to My2K and what My2K thinks is supposed to be on your account. Whether or not that is tied into what the Steam DLC page says, I am unsure.


#6

So that means

  • Steam knows that you own the DLC
  • My2K has no idea regarding that yet

I’d give it some time, maybe play a round or so? Have you tried verifying the game files? :wink:


#7

Ugh… verifying the files has worked, at least for now. I figured uninstalling and reinstalling would have the same effect. Hopefully it stays this way.

Thank you for your help :slight_smile:


#8

Glad it has been fixed for you.

I’ll make sure to suggest that next time someone has the similar problem.

Should there be anything, reply back. I’ll put a mail for the Tom on hold for now. :wink:


#9

Well… I played one custom game with it to get some footage for a skin spotlight. I quit to the menu and went to play another and it was gone again. So unfortunately the cache fix is not permanent :frowning:


#10

Indeed, did more testing and it seems that every time I want to play with the Savage skin I will have to verify my Evolve files. It lasts for one game, and as soon as I get back to the menu it is gone without even exiting the game entirely.