Face Your Fears crashing? Oculus Rift


Hey all, wondering if anyone else has had this problem -

Tried experiencing the storybooks (through the right hand door) and initially I got about a minute in before it crashed. The message I received was “Low level fatal error” and “Unreal engine is exiting due to D3D device being lost.”

I’ve tried downloading older display drivers, the newest display drivers, drivers with the full AMD package, and only the audio and display drivers with none of the superfluous crap they like to throw in. I did completely remove all drivers before trying different ones.

Now, it won’t even let me get into the main menu before crashing and simply giving a bare bones “fatal error” message.

Worth noting - I put my girlfriend into the left door experience (mega robot on a building) and don’t recall having any problems there.

In case it’s helpful, I’m running a Gigabyte R9 380X (which I know is below Oculus mininum specs but has been working just fine for all other titles). Also, MSI Afterburner is constantly running as well (fan control mostly). Intel i5 4690k CPU and 8GB memory.

Really hoping to get this fixed…I experienced two of the storybooks at a friend’s place before getting the Oculus and I absolutely loved them! I want to check all of them out and show them to my girlfriend who is a big horror genre fan.

Thanks for your time!


Thanks for stopping by, Alex! I’m sorry you’re crashing, that sucks :frowning:

Are you able to run other VR games?


I am, all the other titles I own run without any problems - I tried playing some Dead and Buried in between issues with Face Your Fears and everything was normal.


Alright, I’ll see if anyone has any ideas at work tomorrow. Hang tight!


Just tried it again, and the alien robot experience (left door) works perfectly fine with no hiccups or anything.

Any reason that would work and not the right door experiences?


Heya @juxtapaul, I’m sorry that FYF isn’t working properly for you. In situations like this, there are a few potential causes. Let’s run through those and see if we can track it down.

The first possible cause would be a problem with the installation of the driver, but it sounds like you’ve probably covered your bases here. Generally speaking, it’s best to have the latest drivers. You did the right thing by uninstalling previous versions. A few years ago when I was troubleshooting this on a personal PC, I found a utility which would do a “deep uninstall” of video drivers and get rid of files and registry settings left over after an uninstall. You could see if there is something similar floating around now and give that a shot.

The second possible cause would be a bad install of the game. It is possible that a bad asset on the Haunted map is causing the crash. This isn’t very likely, but it’s easy to uninstall the game and download it again, so its worth trying out.

The third possible cause would be some other application interfering with the game and/or the Oculus runtime system. You can use the System Configuration tool to try booting your PC with the most minimal set of startup applications and services required to run the game. It’s also not a bad idea to go through the list of applications installed on your PC and uninstall anything you don’t plan on using again. They can’t interfere if they’re gone! :slight_smile:

The fourth possible cause would be either a bad DirectX call being made by the game / Oculus run time, or a bug in the driver itself. Unfortunately, that’s not something we’ll be able to easily diagnose remotely.

I hope this helps, have a great weekend!


I currently have the latest drivers and actually used two different utilities (an AMD uninstaller and DDU from guru3D) to ensure that all previous drivers have been removed - this is actually something I have to do every time I update my graphics drivers otherwise when installing a new AMD driver it fails to actually update. Kind of a pain, I wish they would just overwrite the previous driver but oh well.

I have also tried uninstalling and reinstalling (I think twice actually) but unfortunately to no avail.

The third cause I have not fully explored and will need to try completely closing ALL other applications but in reality the only other “applications” I have going on are Steam and MSI Afterburner - of course there are background processes but no other apps. It could certainly be one of those two though, so that’s something I’ll try.

As far as the fourth cause goes…I guess if none of the above mentioned possibilities take care of the issue then I can assume it may be a DirectX or Oculus RT problem, and pretty much be hosed at that point? I mean that would be a bummer - but the experience is free, and I could always take a trip to a friend’s house if I really wanted to jump into FYF or show it to someone else.

Thanks for the response @trsbrock ! I’ll post here if I find anything else out. :slight_smile: